SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    Non-Member lostseed's Avatar
    Join Date
    Sep 2005
    Location
    Zurconion Soon!
    Posts
    1,549
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Unknown IE Bug :\

    Not sure about this one, I tried the height 1% bug.
    It only appears shifted in IE. Can anyone please take a look?

    I REALLY cant figure this out please someone must know

    http://www.lostseed.com/audio/index.php

    This is the code for them (just left and right as you see them)

    Code:
    div.articles, div.left {
    	width: 385px;
    	float: left;
    	clear: both;
    	padding: 0;
    	position: relative;
    	margin: 0 0 15px 0;
    }
    	
    div.references, div.right {
    	width: 380px;
    	padding: 0;
    	float: right;
    	position: relative;
    	margin-bottom: 15px;
    }
    Last edited by lostseed; Jul 21, 2006 at 21:48.

  2. #2
    Non-Member lostseed's Avatar
    Join Date
    Sep 2005
    Location
    Zurconion Soon!
    Posts
    1,549
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    its just

    HTML Code:
    <div class="left">content</div>
    <div class="right">content</div>
    
    
    <div class="left">content</div>
    <div class="right">content</div>
    
    
    <div class="left">content</div>
    <div class="right">content</div>

  3. #3
    Non-Member lostseed's Avatar
    Join Date
    Sep 2005
    Location
    Zurconion Soon!
    Posts
    1,549
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ive gone through google and tried a lot of IE hacks.
    I have never encountered this before and have never been stuck on something for this long.

    Would min-height and h/eight do any good? It didnt seem to.

  4. #4
    Non-Member deathshadow's Avatar
    Join Date
    Jul 2006
    Location
    Dublin, NH
    Posts
    901
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    to each of your 'left' tags, add a 'clear:both;"

    That should make them line up.

    -- edit --

    or not, you've already got it there... hmm...

  5. #5
    Non-Member deathshadow's Avatar
    Join Date
    Jul 2006
    Location
    Dublin, NH
    Posts
    901
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm. You didn't close a LI after "LostSeed CD Download" - that doesn't seem to be the issue though.

    Got me stumped... at that point I'd probably just wrap each right/left in a container DIV to force the issue... at which point you are looking at almost as many tags as a table... Hmm... Two columns by 3 rows, yup, SOUNDS like a table to me.

  6. #6
    Non-Member lostseed's Avatar
    Join Date
    Sep 2005
    Location
    Zurconion Soon!
    Posts
    1,549
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Wow I went completely brain dead, Ive been so adopted by CSS I totally forgot tables can still be an option haha. Thanks for this I may try a force div first, otherwise tables always work. Thanks for your suggestions, finally I can do somethig about this

    The LI is closed or else.. Wow, it looks like my Firefox validator missed that !! I cant believe it haha


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •