SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Guru nagrom's Avatar
    Join Date
    Jul 2001
    Location
    Western CT, USA
    Posts
    803
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    SSL secure and unsecured information

    I've been noticing on some of my ecommerce sites lately that when going to secure checkout, I get a 'this page contains some secure and unsecure information' message on some sites, but not others.

    I never used to get this message at all.

    I suspect it comes from calling up images or external scripts outside the SSL layer (like an external style sheet called with an absolute path)

    Does anyone know?

  2. #2
    epsilon transition cupid's Avatar
    Join Date
    Aug 2001
    Location
    Kent, Ohio
    Posts
    367
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SSL secure and unsecured information

    Originally posted by nagrom
    I suspect it comes from calling up images or external scripts outside the SSL layer (like an external style sheet called with an absolute path)

    Does anyone know?
    And you are absolutely right. Having images or scripts outside the secure server will trigger this message. A quick solution: copy them into the secure directory and call them within the secure layer. Redundant, yes, but it rids you of that annoying message.. which might also drive paranoid customers away.

  3. #3
    SitePoint Guru nagrom's Avatar
    Join Date
    Jul 2001
    Location
    Western CT, USA
    Posts
    803
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, Cupid.

    Hey, I was born in Cleveland, the shining star of Ohio.

  4. #4
    epsilon transition cupid's Avatar
    Join Date
    Aug 2001
    Location
    Kent, Ohio
    Posts
    367
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Shining star? Did you mean that or am I sensing sarcasm?

    Nah, it's not that bad. Been here for 11-12 years, it's not a huge city, nor a small one. Just the right size for me. I like it here.

  5. #5
    SitePoint Guru nagrom's Avatar
    Join Date
    Jul 2001
    Location
    Western CT, USA
    Posts
    803
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    well, I was born in 1973, the same year the river caught on fire. thatss right - THE RIVER.

    I didn't live there for long, but I do like the midwest, and it's looking better and better lately too (I'm only an hour from NYC).

    Even if the water's flamable.

  6. #6
    SitePoint Wizard silver trophy
    beley's Avatar
    Join Date
    May 2001
    Location
    LaGrange, Georgia
    Posts
    6,117
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Actually, if you have any images on the page they should reference the HTTPS:// as well or the page will give the error. It means that all "components" on the page are not loading as secure... so somewhere there is a reference (whether it is a script or picture) with HTTP instead of HTTPS - If you have any ABSOLUTE urls that might be where your prob is...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •