SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Member
    Join Date
    Nov 2005
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS, and Internet Explorer Problems...

    Hey guys I am trying to make my site compatiable with IE and its going hard so far.

    I am trying to style H tags in CSS but in IE it won't read them, I was wondering what I have to do to get them to work?

    Here is my current IE-css H1 tag
    HTML Code:
    .h1 {
    	font: Tahoma;
    	font-size: 10pt;
    	color: #386EAC;
    	font-weight: normal;
    }
    What I am doing is <h1 class="h1"></h1>

    I would appriciate the help.

    Thanks again!

  2. #2
    Non-Member
    Join Date
    Jan 2005
    Location
    Netherlands
    Posts
    4,300
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello

    .H1 or H1

    this seems to work

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
    <head>
    <title>12345 12345 12345 12345 12345</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    	<style type="text/css">
    	
    	.h1{
    	font-family: Tahoma,sans-serif;
    	font-size:10pt;
    	color: #386EAC;
    	font-weight:normal;
    	}
    	</style>
    	<script type="text/javascript">
    
    	</script>
    </head>
    <body>
    
    <h1 class="h1">12345</h1>
    </body>
    </html>

  3. #3
    SitePoint Member
    Join Date
    Nov 2005
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Still no workie...

    GRRRRR!!!

  4. #4
    SitePoint Wizard silver trophybronze trophy Nadia P's Avatar
    Join Date
    Oct 2004
    Location
    NSW Australia
    Posts
    3,564
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    in which case a link to the page you are working on would be helpful

    Nadia

  5. #5
    SitePoint Zealot buzza_gts's Avatar
    Join Date
    Oct 2005
    Location
    Melbourne
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What all4nerds posted works fine.

    Does this work, styling for all H1's?

    Code:
    <style type="text/css">	
    	h1 {
    	font-family: Tahoma,sans-serif;
    	font-size:10pt;
    	color: #386EAC;
    	font-weight:normal;
    	}
    </style>
    Have you got you style sheet linked too correctly? Is other styling working?
    Would be able to solve this problem very quickly with a link.

  6. #6
    SitePoint Member
    Join Date
    Nov 2005
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  7. #7
    SitePoint Zealot buzza_gts's Avatar
    Join Date
    Oct 2005
    Location
    Melbourne
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK found your problem in ie-style.css:

    Code:
    .spacer {
    	height: 12px;
    	width: 100%'
    }
    You have a ' instead off ; at the end so all the styling below this was being ignored


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •