SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    Just Blow It bronze trophy
    DaveMaxwell's Avatar
    Join Date
    Nov 1999
    Location
    Mechanicsburg, PA
    Posts
    7,254
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Here is the site address I am having a problem with: www.keystonecapitalchorus.org/index2.shtml

    In IE, the bar down the left hand side lines up with that little curve graphic I've got at the top of my menu. In NN, the bar will not line up for anything. I've beaten my head on the desk for way to long. I'm sure it's REAL simple, but I can't figure out what I am doing wrong.

    I'm also trying to use two different text rollover options to show links. Both the menu bar and the rest of the site are SUPPOSED to reverse highlight the links when a mouse moves over it. In IE, I used the style sheet and everything works grand. NN of course doesn't do well with the style sheets, but I found a javascript on www.javascripts.com which was supposed to emulate the same effect, but I can't get it to work for the life of me. I tried to contact the author of the script, but I got an invalid email message back. Could someone PLEASE take a look at this and tell me what I'm doing wrong?

    Thanks a lot......

    ------------------
    Dave Maxwell
    www.keystonecapitalchorus.org
    www.trademarkquartet.com

  2. #2
    SitePoint Addict
    Join Date
    Feb 2000
    Location
    District of Columbia
    Posts
    373
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you are specifying the cell width (14px) and coloring it blue. Netscape freaks out. Solution? Put a 14x14 px spacer GIF (make it transparent) in that cell (the one that doesn't align) and voila! Netscape is happy )

    I just tried it, it works.

    ::temis

  3. #3
    Just Blow It bronze trophy
    DaveMaxwell's Avatar
    Join Date
    Nov 1999
    Location
    Mechanicsburg, PA
    Posts
    7,254
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Cool! I'll give that a try when I get home.

    Any clues on the mouseover stuff???

    ------------------
    Dave Maxwell
    www.keystonecapitalchorus.org
    www.trademarkquartet.com

  4. #4
    Your Lord and Master, Foamy gold trophy Hierophant's Avatar
    Join Date
    Aug 1999
    Location
    Lancaster, Ca. USA
    Posts
    12,305
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Netscape won't render empty table cells. While the 14X14px transparent gif would work. You could use a 1X1px transparent gif and set its size to 14X14. But then you have the overhead of the gif (around 80 bytes) and the overhead of the code for the image tag (another 20 bytes or more). You could just throw in a non-breaking space using HTML entities and the cell is no longer empty. A non-breaking space is nbsp; preceded by an '&'. This only takes 4 bytes and Netscape will render the cell properly. Now consider 6 bytes versus 100 or more. Now when your trying to get the smallest possible size for your HTML downloads which is a better course of action?

    ------------------
    Wayne Luke
    Internet Media Provider


    [This message has been edited by wluke (edited February 27, 2000).]

  5. #5
    Just Blow It bronze trophy
    DaveMaxwell's Avatar
    Join Date
    Nov 1999
    Location
    Mechanicsburg, PA
    Posts
    7,254
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Wluke:

    The only problem is I do have the   in the cell and it still comes out screwy. I didn't want to have a .GIF in the cell if I didn't have to. Here is the code I'm using:

    <TABLE Width=100% Align=Center border=0 cellpadding=0 cellspacing=0 bgcolor="#050855">
    :
    :menu goes here.
    :
    <TR bgcolor="floralwhite"><TD><IMG SRC="images/menu_bottom_left.gif"
    border=0 width="100" height="48"></TD><TD Align=right valign=top> </TD></TR>
    </TABLE>

    <TABLE WIDTH=100% border=0 cellpadding=0 cellspacing=0><TR>
    <TD WIDTH=14 bgcolor="#050252"> </TD>
    <TD WIDTH=10> </TD>
    <TD>
    :
    :rest of code
    :

    The line I'm having a problem with is the TD WIDTH=14 line. Maybe I'm being dense, but I don't see what is wrong. If you could elaborate a bit more on what I'm doing wrong, I'd appreciate it. Otherwise I'll have to use the transparent gif.

    Thanks for your time.

    ------------------
    Dave Maxwell
    www.keystonecapitalchorus.org
    www.trademarkquartet.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •