SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Wizard Wolf_22's Avatar
    Join Date
    Jul 2005
    Posts
    1,714
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Issue with XAMPP

    I just installed XAMPP, and with the website I'm working on, I'm also using CuteNews.

    Since I've installed XAMPP, I've had to change some include paths in the global.php file as well as the index.php file (these files had include paths that weren't really relative paths).

    I thought I've taken care of the major issues, but when I try to access the login, I get these messages:

    Warning: include(cl_files/calendar.php) [function.include]: failed to open stream: No such file or directory in C:\Program Files\XAMPP\xampp\htdocs\New Website\backend\test\cl_files\index.php on line 25

    Warning: include() [function.include]: Failed opening 'cl_files/calendar.php' for inclusion (include_path='.;C:\Program Files\XAMPP\xampp\php\pear\') in C:\Program Files\XAMPP\xampp\htdocs\New Website\backend\test\cl_files\index.php on line 25

    Fatal error: Call to undefined function read_data() in C:\Program Files\XAMPP\xampp\htdocs\New Website\backend\test\cl_files\index.php on line 27
    Anyone have any ideas what I should do to fix this? Thanks.

  2. #2
    SitePoint Addict betrollwin.com's Avatar
    Join Date
    Nov 2005
    Posts
    213
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ... Are you serious?

    The server is looking for the files on your computer and not the internet. Look at the path you put in: C:\Program Files\...

    Make the path the right one, and it will work.

  3. #3
    SitePoint Wizard Wolf_22's Avatar
    Join Date
    Jul 2005
    Posts
    1,714
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay...

    It's really not as simple as it is apparently sounding. I have XAMPP installed emulating Apache on my Windows XP machine. I am using CuteNews (www.cutephp.com) and a calendar program called "PHP Event Calendar" found here (http://www.softcomplex.com/products/php_event_calendar/).

    The problem I'm having is either with some sort of path issue or else it has some sort of permissions issue because:

    a.) I have looked everywhere within my directories for the directory URL's. I have changed the ones I've found to make be the correct path, but apparently there is something still wrong.

    b.) The "read only" checkbox is "clickable", but when I go to click on it, it REMAINS gray. SO, despite the fact that it's grayed-out, it's still clickable, and when I press "ok" to submit my alternate click, I'll go back to my folder's properties and it grays-out again.

    Despite my awareness of these facts, I'm unable to locate the root of evil. I'll quadruple check the paths again, but if I come up empty handed, do you have any other suggestions? I tried the localhost FTP method to change the CHMods, and although I was able to access the folder, changes made to the folder attributes ended up to no avail.

    Thanks

  4. #4
    SitePoint Addict betrollwin.com's Avatar
    Join Date
    Nov 2005
    Posts
    213
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hm.. Do you have an error log? Post it up here if you have.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •