SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Oct 2005
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry Bug in ie6 - Surprise!!

    Hey there,

    This has been flipping me out. If you have a look here
    you'll see this strange ie bug. About every fourth time the page is loaded, some of the bottom link - "Solid Silk Shirt" - appears just after my productPage div.

    I've come across this before and read that it's something to do with anchors being too close to the edge of floated divs. The suggested fix was setting a margin or padding, but this doesn't seem to be working for me. It seems to happen to whatever div is last in the productPage div.

    Here's the css for the entities involved:

    #productPage
    {
    float:left;
    clear:none;
    width:640px;
    margin-top:10px;
    padding:0 5px 3px 3px;
    }

    The "Goes With" panel:

    #relatedProducts
    {
    float:right;
    width:90px;
    text-align:center;
    margin: 0 3px 10px 0px;
    background-image:url(images/navLeftBottom.gif);
    background-position:bottom left;
    background-repeat:no-repeat;
    }

    div.panelHead
    {
    font-weight:bold;
    color:#fff;
    font-size:12px;
    padding:0px 5px 3px 5px;
    margin-bottom:2px;
    width:90px;
    background-image:url(images/navLeftTop.gif);
    background-position:top left;
    background-repeat:no-repeat;
    background-color:#A57EA5;
    }
    /* Override for IE box model bug */
    html>body div.panelHead
    {
    width:80px;
    }

    .panelContents
    {
    width:90px;
    text-align:center;
    border-right:1px solid #e5e5e5;
    border-left:1px solid #e5e5e5;
    }
    html>body div.panelContents
    {
    width:82px;
    }

    .panelProduct
    {
    float:left;
    clear:left;
    padding:3px 3px 8px 3px;
    width:88px;
    }

    Can anyone help me with this mania??

  2. #2
    SitePoint Wizard HarryR's Avatar
    Join Date
    Dec 2004
    Location
    London, UK
    Posts
    1,376
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This isn't a fix for your question above, but just a quick note about Opera (9 final/linux):


  3. #3
    SitePoint Member
    Join Date
    Oct 2005
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks. I just fixed that - I've been playing around with productPage paddings to try to fix the problem, forgot to account for the box model bug

  4. #4
    SitePoint Wizard drhowarddrfine's Avatar
    Join Date
    Aug 2005
    Posts
    3,438
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Remove everything in front of your doctype. This puts IE into quirks mode.

  5. #5
    SitePoint Member
    Join Date
    Oct 2005
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just tried that, but it didn't get rid of the error and actually made a whole bunch of other weird stuff happen. I'll keep it in mind when starting from scratch in the future, though.

    Any other ideas?

  6. #6
    SitePoint Member
    Join Date
    Oct 2005
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've sorted it out in a hacky way. The problem has to do with floated divs with anchors near their borders. I finally sorted it out by changing my divs from float:left to display:inline (I suppose they could be spans now - who cares, at least its working )


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •