SitePoint Sponsor

User Tag List

Results 1 to 7 of 7

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Jun 2001
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Personal Web Server

    I am trying to export an access 200 table to an asp, view and edit it in localhost .
    I am able to view it but it is not editable.
    I have done it before but can't get it to work this time.
    I think it might be because of the DSN I created.
    I am using Windows 98.
    For the DSN I specified a name. Chose *.mdb for the connection and chose the database to connect to.
    That is all I did. (that's all I thought I did last time also)
    What am I missing?

    Thanks again,

    Carol:

  2. #2
    SitePoint Wizard Aes's Avatar
    Join Date
    Jun 2001
    Location
    Oklahoma
    Posts
    3,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This thread should be moved to a more appropriate forum; you'll get better responses there.
    Colin Anderson
    Ambition is a poor excuse for those without
    sense enough to be lazy.

  3. #3
    SitePoint Member
    Join Date
    Jun 2001
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for letting me know.

    Any idea where would be appropriate?
    I'm a complete beginner.
    Thanks
    Carol

  4. #4
    SitePoint Wizard Aes's Avatar
    Join Date
    Jun 2001
    Location
    Oklahoma
    Posts
    3,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Don't worry about it; an advisor should move it shortly. You weren't exactly in the wrong, so to speak, about posting it here. It should be moved just because the members who are likely to know how to answer your question are more likely to see this thread in onw of the other channels.
    Colin Anderson
    Ambition is a poor excuse for those without
    sense enough to be lazy.

  5. #5
    SitePoint Wizard iTec's Avatar
    Join Date
    May 2001
    Location
    Sydney, Australia
    Posts
    2,243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    carol if you can view the data from the database, but not write to the database then it is not a problem with your dsn. it is most likely a problem with your code whe trying to write to the database, did you write/buy/download the code?

    also are there any error messages that appear when you try to edit the code? if so posting it here might help track were the problem lies.

  6. #6
    SitePoint Member
    Join Date
    Jun 2001
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Personal Web Server

    When you use the export function from Access 2000 to create an asp page it generates the code for you. see below.
    I navigated the where I saved the form using internet explorer.
    http://localhost/filename.asp to view it. It worked a few months ago. Could something in my Personal Web Server not be set up right? scripts is enabled and read is enabled. By the way I reposted this to ASP forum yesterday. I didn't mean to have 2 threads going.
    Sorry
    Thanks
    Carol


    <HTML>
    <HEAD>
    <META HTTP-EQUIV="Content-Type" CONTENT="text/html;charset=windows-1252">
    <TITLE>tblCity</TITLE>
    </HEAD>
    <BODY>
    <%
    If IsObject(Session("tblCity_conn")) Then
    Set conn = Session("tblCity_conn")

    Else
    Set conn = Server.CreateObject("ADODB.Connection")
    conn.open "tblCity","",""
    Set Session("tblCity_conn") = conn

    End If
    %>
    <%
    If IsObject(Session("tblCity_rs")) Then
    Set rs = Session("tblCity_rs")
    Else
    sql = "SELECT * FROM [tblCity]"
    Set rs = Server.CreateObject("ADODB.Recordset")
    rs.Open sql, conn, 3, 3
    If rs.eof Then
    rs.AddNew
    End If
    Set Session("tblCity_rs") = rs
    End If
    %>
    <TABLE BORDER=1 BGCOLOR=#ffffff CELLSPACING=0><FONT FACE="Arial" COLOR=#000000><CAPTION><B>tblCity</B></CAPTION></FONT>

    <THEAD>
    <TR>
    <TH BGCOLOR=#c0c0c0 BORDERCOLOR=#000000 ><FONT SIZE=2 FACE="Arial" COLOR=#000000>City</FONT></TH>
    <TH BGCOLOR=#c0c0c0 BORDERCOLOR=#000000 ><FONT SIZE=2 FACE="Arial" COLOR=#000000>Hyperlink</FONT></TH>

    </TR>
    </THEAD>
    <TBODY>
    <%
    On Error Resume Next
    rs.MoveFirst
    do while Not rs.eof
    %>
    <TR VALIGN=TOP>
    <TD BORDERCOLOR=#c0c0c0 ><FONT SIZE=2 FACE="Arial" COLOR=#000000><%=Server.HTMLEncode(rs.Fields("City").Value)%><BR></FONT></TD>
    <TD BORDERCOLOR=#c0c0c0 ><U><FONT SIZE=2 FACE="Arial" COLOR=#0000ff><%=Server.HTMLEncode(rs.Fields("Hyperlink").Value)%><BR></FONT></U></TD>

    </TR>
    <%
    rs.MoveNext
    loop%>
    </TBODY>
    <TFOOT></TFOOT>
    </TABLE>
    </BODY>
    </HTML>

  7. #7
    SitePoint Member
    Join Date
    Jun 2001
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Did I do something Wrong?

    Did I do something Wrong? or is this something that nobody here knows about.
    If anyone can explain DSN's to me. (the little bit I know came from the Access 2000 developer's handbook.

    I'm pretty sure it is something I am doing wrong in my DSN set up.
    Desparately still trying.
    Carol


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •