SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Enthusiast
    Join Date
    Sep 2005
    Location
    Paris, France
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Li > Ul big margin by IE

    Hi all,

    I was attempting a new design idea for my web app today and I stumbled across an IE bug that is getting me crazy.

    The nav is a vertical ul in wich for each li element there is one below that is hidden until you hover the first. The second li holds another Ul that lists sub items.

    Works great under firefox and safari but IE 6 & 7 just won't display it correctly. It adds a blank space above the sub items.

    The page can be seen at : http://www.jobalistic.com/bugged.html

    The page styles are here :
    http://www.jobalistic.com/layout.css

    And the menu styles are there :

    http://www.jobalistic.com/menu.css

    I would greatly appreciate any help or advice you could provide since this got me stuck for the last two hours...


    Thanks in advance


    Sebastien

  2. #2
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You've got no doctype, IE is in quirks mode using the broken box model which means it treats dimensions differently.

  3. #3
    SitePoint Enthusiast
    Join Date
    Sep 2005
    Location
    Paris, France
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,

    Thanks for the idea but whatever the doctype, doesn't change anything.


    Sebastien


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •