SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2001
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    why is php_gd not installed?

    Hi

    I have resently installed a gd support on php4 on my windows platform and i just copyed the dll file into the DIR /extension and putted the required line
    ;extension=php_gd.dll
    into php.ini

    the php_info();

    show that the GD support is enabled but itīs not working,

    I tryed now to check with IF statement wheiter the module was on or not:


    PHP Code:
    IF (extension_loaded(php_gd.dll)) {
        print (
    "yeah heīs loaded!");
    }
    else

        print (
    "men! itīs not loaded!");

    it return the false statement

    but the Gd is working fine now beacause
    i just loaded it directly with
    DL("php_gd.dll");
    before i loaded the GD syntaxes

    Well this is a solution in the end

    But why is it not working before i used the DL() ???

    Do i have to recompile php? on a a windows platform?

  2. #2
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you restart your web server after placing gd.dll in the extensions folder? If not then PHP won't have loaded it, so your DL() option works cause its loading it dynamically, you must restart the server to get the dll loaded into runtime
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  3. #3
    SitePoint Enthusiast
    Join Date
    Jun 2001
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    offcours did i restart it

  4. #4
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well that would be the number one mistake, so I guess you made it past that one. Okay I just noticed you said you put

    Code:
    ;extension=php_gd.dll
    into your php.ini file. That is the wrong syntax, the semicolon means comment this line out. It should be

    Code:
    extension=php_gd.dll
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  5. #5
    SitePoint Enthusiast
    Join Date
    Jun 2001
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    dddddaaaaaaaaaaaa

    Offcours it donīt work men!

    this is the php.ini file where the modules are loaded

    PHP Code:
    ;Windows Extensions
    ;Note that MySQL and ODBC support is now built inso no dll is needed for it.
    ;
    ;
    extension=php_bz2.dll
    ;extension=php_ctype.dll
    ;extension=php_cpdf.dll
    ;extension=php_curl.dll
    ;extension=php_cybercash.dll
    ;extension=php_db.dll
    ;extension=php_dba.dll
    ;extension=php_dbase.dll
    ;extension=php_domxml.dll
    ;extension=php_dotnet.dll
    ;extension=php_exif.dll
    ;extension=php_fdf.dll
    ;extension=php_filepro.dll
    ;extension=php_gd.dll
    ;extension=php_gettext.dll
    ;extension=php_ifx.dll
    ;extension=php_iisfunc.dll
    ;extension=php_imap.dll
    ;extension=php_interbase.dll
    ;extension=php_java.dll
    ;extension=php_ldap.dll
    ;extension=php_mhash.dll
    ;extension=php_mssql65.dll
    ;extension=php_mssql70.dll
    ;extension=php_oci8.dll
    ;extension=php_openssl.dll
    ;extension=php_oracle.dll
    ;extension=php_pdf.dll
    ;extension=php_pgsql.dll
    ;extension=php_printer.dll
    ;extension=php_sablot.dll
    ;extension=php_snmp.dll
    ;extension=php_sybase_ct.dll
    ;extension=php_yaz.dll
    ;extension=php_zlib.dll 
    all this lines are "comment" out like the help text in the file so all this modules are not loaded.


    Silly me!!!!!!!!!!!

    thanks for the help dude


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •