SitePoint Sponsor

User Tag List

Results 1 to 13 of 13
  1. #1
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    [rails] problem installing on red hat 9

    Following through : http://wiki.rubyonrails.com/rails/pa...ed+Hat+Linux+9

    I get to this stage:

    Code:
    $ rpm -q httpd
     > httpd-2.0.40-21.11 
    $ rpm -q httpd-devel
     > package httpd-devel is not installed 
    $ up2date httpd-devel
    And I get a fatal rpm error:

    There was a rpm unpack error installing the package: httpd-2.0.52-22.ent.centos4

    I'm not sure why I'm getting stuck here.

    I'm pretty sure I've installed ruby, rubygems and rails correctly as i followed: http://wiki.rubyonrails.com/rails/pa...ed+Hat+Linux+9
    and all went without a hitch.

    My apache is at /usr/local/apache/

  2. #2
    SitePoint Guru
    Join Date
    Aug 2005
    Posts
    986
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you want to set up a development server, or a production server?

    Webrick, Rails' built in webserver is ideal for development. You start it with
    $ ruby script/server
    (assumed your wd is your app)

    If you are setting up a production server, lighthttpd is recommended. Apache is ok too, but it is harder to set up. I don't know how to fix your problem if you prefer Apache...

  3. #3
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm setting it up on a dedicated server - so apache is a must. This is a production server as well so webrick is unsuitable, I've got apache2+rails+fastcgi running on my test server at home fine (although it was admittedly troublesome) so I should be able to get it working on this server but am still stuck at this stage.

  4. #4
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This is what happens in the shell:

    Code:
    [root@server1 temp]# up2date httpd
    
    Fetching Obsoletes list for channel: centos4-Base...
    
    Fetching Obsoletes list for channel: centos4-Updates...
    
    Fetching Obsoletes list for channel: centos4-extras...
    
    Fetching Obsoletes list for channel: centos4-addons...
    
    Fetching rpm headers...
    ########################################
    
    Name                                    Version        Rel
    ----------------------------------------------------------
    httpd                                   2.0.52         22.ent.centos4    i386
    
    
    Testing package set / solving RPM inter-dependencies...
    
    Downloading headers to solve dependencies...
    ########################################
    httpd-2.0.52-22.ent.centos4 ########################## Done.
    httpd-suexec-2.0.52-22.ent. ########################## Done.
    Preparing              ########################################### [100%]
    
    Installing...
       1:httpd                  warning: /etc/httpd/conf.d/welcome.conf created as /etc/httpd/conf.d/welcome.conf.rpmnew
    warning: /etc/httpd/conf/httpd.conf created as /etc/httpd/conf/httpd.conf.rpmnew
    warning: /etc/httpd/conf/magic created as /etc/httpd/conf/magic.rpmnew
    ########################################### [100%]
    error: unpacking of archive failed on file /etc/httpd/logs: cpio: rename
    There was a fatal RPM install error. The message was:
    There was a rpm unpack error installing the package: httpd-2.0.52-22.ent.centos4

  5. #5
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Very little in google on this error - but it looks like the /etc/httpd folder is actually a link to /usr/local/apache so this might be why its going wrong?

  6. #6
    Mal Reynolds Mandibal's Avatar
    Join Date
    Aug 2003
    Location
    Columbus
    Posts
    718
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I found this message on a mailing list:

    Hi Larry, I think the default is for the package to install /etc/
    httpd/logs as a symlink to /var/log/httpd/. If you've changed /etc/
    httpd/logs to be a real directory, that would be why the package is
    complaining. If that's the case, try reverting it to a symlink, and
    then doing a yum update.
    The guy he was responding to was using yum though, but The error was the same I think and references the same spot your install fails which is the log dir.

    Another suggestion would be to just skip the RPM install and do a normal build of Apache. I've never had a problem do Apache builds from source and have had more problems trying to do RPM udpates. Don't know why considering they are supposed to make things easier.
    Erh

  7. #7
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm, thanks mandibal - my /etc/httpd/ is currently set up as a symlink to /usr/local/apache so that might be where its going wrong, i will try making the logs in /usr/local/apache symlink to /var/log/httpd/

    I've never had a problem do Apache builds from source and have had more problems trying to do RPM udpates.
    Ya, I would do that mate but firstly i dont own the server and there are other people with sites on it so im trying to get it up and running without rebuilding, simply because im completely new to linux etc, although i learnt the basics of the shell pretty rapidly i find it best to stick to the guidance documentation.

  8. #8
    Mal Reynolds Mandibal's Avatar
    Join Date
    Aug 2003
    Location
    Columbus
    Posts
    718
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Bob Carologees
    Ya, I would do that mate but firstly i dont own the server and there are other people with sites on it so im trying to get it up and running without rebuilding, simply because im completely new to linux etc, although i learnt the basics of the shell pretty rapidly i find it best to stick to the guidance documentation.
    Definitely understandable. You don't want to cause an interuption for other users. Let us know how it progresses. Also, since this isn't Rails specific but more of an Apache question you might want to ask in the server management or Apache configuration sections to see if anyone has had a similar experience.
    Erh

  9. #9
    SitePoint Evangelist
    Join Date
    Apr 2005
    Posts
    485
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    fire up your irc client and go to #rubyonrails .

    it is worth a shot.

    if you get this figured out, i'd appreciate it if you would post your steps so others could learn from it. RoR on Red Hat with Apache is probably a popular choice.

  10. #10
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Mandibals suggestion cleared it up a treat, just make sure /etc/httpd/ is a symlink to var/log/httpd.

    I now have another problem though, it seemed like the rest of the installation went without a hitch, but when running dispatch.cgi through ruby to test it out I receive a hideous number of errors:

    Code:
    Exception `NameError' at ./public/../config/boot.rb:14 - uninitialized constant Rails
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/validations.rb:334: warning: `*' interpreted as argument prefix
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/validations.rb:363: warning: `*' interpreted as argument prefix
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/migration.rb:224: warning: instance variable @ignore_new_methods not initialized
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/migration.rb:224: warning: instance variable @ignore_new_methods not initialized
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:41: warning: method redefined; discarding old allow_concurrency=
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/connection_adapters/sqlserver_adapter.rb:456: warning: method redefined; discarding old remove_column
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- db2/db2cli
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- db2/db2cli
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- db2/db2cli
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/connection_adapters/oracle_adapter.rb:119: warning: (...) interpreted as grouped expression
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- oci8
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- oci8
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- oci8
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- oci8
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- oci8
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- oci8
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/kernel/requires.rb:19 - no such file to load -- oci8
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- sybsql
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- sybsql
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- sybsql
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/request.rb:169: warning: method redefined; discarding old relative_url_root
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- Win32API
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- Win32API
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- Win32API
    /usr/lib/ruby/1.8/cgi/session/pstore.rb:17: warning: method redefined; discarding old []=
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/cgi_ext/raw_post_data_fix.rb:57: warning: ambiguous first argument; put parentheses or even spaces
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/cgi_ext/raw_post_data_fix.rb:8: warning: method redefined; discarding old initialize_query
    Exception `DRb::DRbServerNotFound' at /usr/lib/ruby/1.8/drb/drb.rb:1647 - DRb::DRbServerNotFound
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- memcache
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- memcache
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- memcache
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/session/active_record_store.rb:129: warning: private attribute?
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/session/active_record_store.rb:179: warning: method redefined; discarding old connection
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_view/helpers/prototype_helper.rb:640: warning: ambiguous first argument; put parentheses or even spaces
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_view/helpers/prototype_helper.rb:873: warning: `*' interpreted as argument prefix
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- redcloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- redcloth
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- redcloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- redcloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- redcloth
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- redcloth
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/kernel/requires.rb:19 - no such file to load -- redcloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- bluecloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- bluecloth
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- bluecloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- bluecloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- bluecloth
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- bluecloth
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/kernel/requires.rb:19 - no such file to load -- bluecloth
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- html/tokenizer
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- html/tokenizer
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- html/tokenizer
    /usr/lib/ruby/gems/1.8/gems/actionmailer-1.2.1/lib/action_mailer/vendor/tmail/facade.rb:486: warning: method redefined; discarding old create_reply
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- tmail/base64.so
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- tmail/base64.so
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- tmail/base64.so
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- tmail/scanner_c.so
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- tmail/scanner_c.so
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- tmail/scanner_c.so
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- xml/parser
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- xml/parser
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- xml/parser
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- xml/parser
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- xml/parser
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- xmlscan/scanner
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- xmlscan/scanner
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- xmlscan/scanner
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- xmlscan/scanner
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- xmlscan/scanner
    Set XSD::XMLParser::REXMLParser as XML processor.
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- http-access2
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- http-access2
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- http-access2
    Loading http-access2 failed.  Net/http is used.
    /usr/lib/ruby/gems/1.8/gems/actionwebservice-1.1.2/lib/action_web_service/protocol/xmlrpc_protocol.rb:6: warning: discarding old message
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:581: warning: method redefined; discarding old []=
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:590: warning: method redefined; discarding old []
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:595: warning: method redefined; discarding old keys
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:600: warning: method redefined; discarding old find_pair
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:607: warning: method redefined; discarding old []=
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:611: warning: method redefined; discarding old []
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:615: warning: method redefined; discarding old method_missing
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:483: warning: instance variable @after_initialize_block not initialized
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- fcgi
    generated_code/routing/generation.rb:1: warning: redefine generate_default_path
    generated/routing/recognition.rb:1: warning: redefine recognize_path
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - no such file to load -- simplecc
    Exception `MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - no such file to load -- simplecc
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150 - no such file to load -- simplecc
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/breakpoint.rb:463: warning: redefine parse_opts
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140 - no such file to load -- /home/tfm/public_html/tfm/.irbrc
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:143 - no such file to load -- /home/tfm/public_html/tfm/.irbrc
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140 - no such file to load -- application_api.rb
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:143 - no such file to load -- application_api.rb
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:32 - no such file to load -- application_api.rb
    Exception `MissingSourceFile' at /usr/lib/ruby/gems/1.8/gems/actionwebservice-1.1.2/lib/action_web_service/container/action_controller_container.rb:68 - Missing API definition file in apis/application_api.rb
    Exception `ActionController::RoutingError' at /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/routing.rb:488 - Recognition failed for ""
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/cgi_process.rb:103: warning: instance variable @session not initialized
    /usr/lib/ruby/1.8/cgi/session.rb:304: warning: instance variable @data not initialized
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/components.rb:119: warning: instance variable @flash not initialized
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/components.rb:121: warning: instance variable @parent_controller not initialized
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/flash.rb:155: warning: instance variable @flash not initialized
    /usr/lib/ruby/1.8/cgi/session/pstore.rb:18: warning: instance variable @write_lock not initialized
    Exception `NoMethodError' at /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/whiny_nil.rb:35 - You have a nil object when you didn't expect it!
    The error occured while evaluating nil.downcase
    Status: 500 Internal Server Error
    Content-Type: text/html
    Now, the wiki says:

    It means that /usr/local/lib/libfcgi.so cannot be found by the dynamic linker’s configuration. Ruby’s fcgi links against -L”/usr/lib”, you can copy the FastCGI? libraries into /usr/lib:
    I've checked /usr/lib and libfcgi is definitely there. I can't see why I am getting all of those missing source files as the installations went through fine and rails is definitely installed as I've already set up a new app.

  11. #11
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oh dear, I've destroyed the server somehow, the owner is going to kill me

    I'm getting

    Code:
    Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: ap_signal
    And that happens on all modules if i comment any particular one out - ive tried rebuiding apache from whm and i even restored the httpd.conf from before i even started rails, ive tried getting rid of fastcgi completely just incase that went wrong but its totally screwed, No idea how that happened

  12. #12
    SitePoint Evangelist
    Join Date
    Apr 2005
    Posts
    485
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Bob Carologees
    Oh dear, I've destroyed the server somehow, the owner is going to kill me

    I'm getting

    Code:
    Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: ap_signal
    And that happens on all modules if i comment any particular one out - ive tried rebuiding apache from whm and i even restored the httpd.conf from before i even started rails, ive tried getting rid of fastcgi completely just incase that went wrong but its totally screwed, No idea how that happened
    Bob, did you back out your symlink and other changes that you made? try and list everything you did and then back them off, one by one, until you figure out what happened.

    sorry to hear about the loss. hopefully, it is recoverable via backup if you can't get it operational again.

  13. #13
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks SKeeter, yes I did try and revert to backups I made but really I made so many ammendments trying to get it working there was no way I could find exactly what had caused it, in the end I managed to reinstall apache and have backup of the original conf so should be ok, just a lot of the modules are missing so the guy can just get his hosts to revert to a tape backup and that should be ok.

    It seems my rails install was fine until I got to setting up fastcgi, and this was because I followed apache 2 instructions without realising the server actually had 1.3!!!! Just goes to show you should never assume. I also had massive problems even reinstalling apache, it kept giving me problems even with the default configs and suddenly i realised that the apachectl was being called from usr/sbin/httpd which was for some reason a 2.5.2 version? As soon as I called apache/bin/apachectl start it booted up fine.

    So now I just need to wait for them to roll back the hard disk, and go through it all again, THIS TIME making sure I set up fastcgi in the right way.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •