SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict nabeel's Avatar
    Join Date
    Nov 2002
    Location
    in westchester county, ny
    Posts
    203
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Clearing form elements

    Hey guys,

    I'm pretty sure that this is where this goes, but here ya go:
    Hey all,

    http://www.myubcard.com/testSite/sea...ts=10&type=and

    If you goto that page, then in the search box, type "campus cash".
    in the example of campus cash, it shows:

    Displaying results 21 - 30 of 64 matches (0.01 seconds)

    Displaying results 1 - 10 of 751 matches (0.01 seconds)

    Displaying results 1 - 10 of 89 matches (0.01 seconds)

    Displaying results 1 - 10 of 89 matches (0.01 seconds)

    Displaying results 1 - 10 of 89 matches (0.01 seconds)

    Displaying results 1 - 10 of 89 matches (0.01 seconds)

    Displaying results 1 - 10 of 89 matches (0.01 seconds)

    Displaying results 1 - 10 of 89 matches (0.01 seconds)

    Displaying results 1 - 10 of 89 matches (0.01 seconds)
    1. [100.00%] Campus Dining & Shops
    I've been going crazy, and can't quite figure out why it's going that.
    It'll do something similar if you type in a query or something, then erase it and type in something else.

    It should be clearing the DIV before it puts anything in. I don't think it's the script that it's calling because it's completely seperate queries.

    Now, in IE, it works properly, but in Firefox, it doesn't clear the div.

    Any ideas/suggestions, I'm sure there's a better way to do it.
    The code is all on the page, just "View Source" it.

    Thanks!
    Nabeel

  2. #2
    SitePoint Addict nabeel's Avatar
    Join Date
    Nov 2002
    Location
    in westchester county, ny
    Posts
    203
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ahh nevermind, stupid mistake! Had two div's named the same thing

  3. #3
    SitePoint Wizard
    Join Date
    Nov 2004
    Location
    Nelson BC
    Posts
    2,310
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I didn't see any problems in Firefox... did you fix it?

    A comment though - this seems to be a case of using Ajax "because it's there".

  4. #4
    SitePoint Addict nabeel's Avatar
    Join Date
    Nov 2002
    Location
    in westchester county, ny
    Posts
    203
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by jimfraser
    I didn't see any problems in Firefox... did you fix it?

    A comment though - this seems to be a case of using Ajax "because it's there".
    Yeah, I fixed it. Thanks.

    I know, there's really no point in using it, it's kind of a "demo"/"proof of concept" to the higher-ups/experimenting with things


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •