SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    cant get fcgi working

    running apache 2, windows xp, latest ruby/rails - works fine with cgi, followed the official guide on setting up fcgi and the welcome to rails page works but when loading the app it says rails application failed to start. - in the log there is something about fcgi communication failed due to getoverlapped or something.

    I've googled and searched on it, tried a couple of different solutions like deleting cookies and changing dispatch.fcgi path to c:/ruby/bin/rubyw.exe etc. all to no avail.

    For the record ive:
    edited htacess to point to dispatch.fcgi
    removed htaccess server config and added in virtual host in apache config
    checked shebang line in dispatch.fcgi
    loadmodule fcgimodule.dll in apache config
    mod_rewrite on

    anything ive missed or any ideas what could be the problem here? tia

  2. #2
    SitePoint Evangelist
    Join Date
    Feb 2006
    Location
    Worcs. UK
    Posts
    404
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you installed Rubyforapache? It installs a module file mod_fastcgi.so. If you use Apache 1.3 you then have to specifically reference that .so file. I don't think you have to with Apaphe 2, but you still need the file.

  3. #3
    Non-Member
    Join Date
    Jul 2005
    Posts
    606
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yeh i kind of realised today that i missed that part at work still so havent had a chance to try it out, should of realised ruby would need fastcgi installed as well


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •