SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Enthusiast
    Join Date
    Dec 2005
    Posts
    61
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help needed setting up IIS and mail

    This is my first time setting up a mail server on IIS so dont have any idea where to start really.

    I am using the PHPMailer script which I downloaded from http://phpmailer.sourceforge.net/.

    This is the code I am using to send the mail.

    PHP Code:
    require 'phpmailer/class.phpmailer.php';

    $mail = new phpmailer();
        
    $mail->From 'you@yourdomain.com';
    $mail->FromName Your Name;
    $mail->Subject 'Test Message';
    $mail->Body 'This is a test message';    
    $mail->AddAddress('you@yourdomain.com''Your Name');
        
    if (!
    $mail->Send())
    {
        echo (
    'failed');
    }
    else
    {
        echo (
    'sent');

    My script, when executed, echo's 'failed', for a failed result.

    Where do I go from here? What do I check/fix?

    HELP!

  2. #2
    SitePoint Addict
    Join Date
    Sep 2004
    Location
    Kelowna, BC
    Posts
    202
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Is SMTP installed? You also require both the to/from in order to send an email.

    Right-click on "My Computer", and then "Manage". Look under Services and Applications, and then Internet Information Server. An SMTP server should be listed there and if there isn't, go back into the add/remove programs, use the windows components, and you'll need to dig thru there to install it.

  3. #3
    SitePoint Enthusiast
    Join Date
    Dec 2005
    Posts
    61
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, SMTP is installed and running


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •