SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Thread: phpAdmin setup

  1. #1
    SitePoint Addict ozmart2004's Avatar
    Join Date
    Feb 2004
    Location
    Albury, NSW, Australia
    Posts
    215
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    phpAdmin setup

    I have installed MySQL 5 and now am trying to install phpmyadmin 2.8.0.1

    I have copied the default config file to create my config.inc.php and I have amended the the user and password.

    I had to chnage the authentication type to 'http' as I kept getting an error for 'config'

    Now when it tries to connect to MySQL it throws up a prompt and despite putting in the correct credentials it just dissappears/reappears blank and won't accept them.

    I have $cfg['PmaAbsoluteUri'] = ' http://localhost/phpMyAdmin-2.8.0.1';

    Here's the top part of my config file...I think it is correct. Can anyone advise me on this?

    Thks

    Code:
    $cfg['Servers'][$i]['host']          = 'localhost'; // MySQL hostname or IP address
    $cfg['Servers'][$i]['port']          = '3306';      // MySQL port - leave blank for default port
    $cfg['Servers'][$i]['socket']        = '';          // Path to the socket - leave blank for default socket
    $cfg['Servers'][$i]['connect_type']  = 'tcp';       // How to connect to MySQL server ('tcp' or 'socket')
    $cfg['Servers'][$i]['extension']     = 'mysql';     // The php MySQL extension to use ('mysql' or 'mysqli')
    $cfg['Servers'][$i]['compress']      = FALSE;       // Use compressed protocol for the MySQL connection
                                                        // (requires PHP >= 4.3.0)
    $cfg['Servers'][$i]['controluser']   = '';          // MySQL control user settings
                                                        // (this user must have read-only
    $cfg['Servers'][$i]['controlpass']   = '';          // access to the "mysql/user"
                                                        // and "mysql/db" tables).
                                                        // The controluser is also
                                                        // used for all relational
                                                        // features (pmadb)
    $cfg['Servers'][$i]['auth_type']     = 'http';      // Authentication method (config, http or cookie based)?
    $cfg['Servers'][$i]['user']          = 'root';      // MySQL user
    $cfg['Servers'][$i]['password']      = 'password'; // MySQL password (only needed
                                                        // with 'config' auth_type)

  2. #2
    SitePoint Addict ozmart2004's Avatar
    Join Date
    Feb 2004
    Location
    Albury, NSW, Australia
    Posts
    215
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Since found this:

    In MySQL Version 4.1, the MySQL developers upgraded the process used to authenticate users. The password hash used in authentication was increased from 16 to 41 bytes, and the hashes were made more secure.

    One side effect of this is that versions of MySQL clients older than version 4.1 cannot talk to a version 4.1 server, because old clients will not be able to give the proper password hashes.

    To configure a single account to use the old protocols, set the password for the account using a 16 byte hash:

    mysql> SET PASSWORD FOR ísome_userí@ísome_hostí = OLD_PASSWORD(ímypassí);

    When MySQL detects an 16 byte hash, it will authenticate the account using the older password hasing system and older client applications will be able to connect.

    It seemed to work. :-)

  3. #3
    SitePoint Addict ozmart2004's Avatar
    Join Date
    Feb 2004
    Location
    Albury, NSW, Australia
    Posts
    215
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I almost have it...[sigh]...now I get a warning:

    The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results.
    I have sussed that the mbstring is now part of a separate package called 'php-mbstring' and I have that dll in my Zend server folder...does this mean I can disregard this warning or do I need to do something?

  4. #4
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    just because it's in the folder doesn't mean it's enabled. you have to add it to your php.ini file and restart your web server.

  5. #5
    play of mind Ernie1's Avatar
    Join Date
    Sep 2005
    Posts
    1,252
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    just uncomment this in php.ini
    extension=php_mbstring.dll

    and restart the web server


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •