SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Enthusiast snorky's Avatar
    Join Date
    Jul 2003
    Location
    Great Northwet
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Background Colors in Forms

    I have a form which displays correctly in FireFox. In IE, 2 of the 3 fields appear with a pale yellow (#FCFEA4) background color. Why is this, and how can I fix it?

    There is only 1 style sheet, and everything else conforms to the sheet. Remember: this problem is in IE, not FireFox. My task is to make it render correctly in IE.


    <FORM ACTION="/bbp/t11s.php" METHOD="GET" name="lastform">

    <div style="padding-left:10px;font-family:monospace;">
    First Name <input type=text value="" name="fname">
    </div>

    <div style="padding-left:10px;font-family:monospace;">
    &nbsp;Last Name <input type=text value="" name="lname">
    </div>

    <div style="padding-left:10px;font-family:monospace;">
    &nbsp;&nbsp;Building <input type=text value="" name="bld">
    </div>

    <br>

    <div style="padding-left:75px;"><input type="Submit" value=" Post Information " /></div>

    </form>


    Here's how that bad boy looks:
    Snorky
    Bless the little children while they're still too young to hate.
    - Tom T. Hall

  2. #2
    SitePoint Wizard
    Join Date
    Mar 2001
    Posts
    3,537
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, if that were the only thing on the page, the fields wouldn't be yellow.

    1) Let's see the style sheet and any links to external style sheets: e.g.

    <link href="mystyle.css" rel="stylesheet" type="text/css">

    2) Are there any <script> tags on the page? If so, what is between them, or in the alternative what is in the file listed as the src?

  3. #3
    SitePoint Wizard silver trophy
    Join Date
    Mar 2006
    Posts
    6,132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    this is caused by that damn google bar.

    theres ways to override it.

    ironically, im going to tell you to google for:
    google bar yellow fields

  4. #4
    SitePoint Enthusiast snorky's Avatar
    Join Date
    Jul 2003
    Location
    Great Northwet
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Google toolbar is causing the problem.

    ClamCrusher was right!

    It's the Google toolbar that is causing the problem.

    Toogle the toolbar off, and all of the fields' backgrounds are white.
    Toogle the toolbar on, and some of the fields' backgrounds are yellow.

    A big HUZZA! for Clamcrusher.

    Snorky
    Bless the little children while they're still too young to hate.
    - Tom T. Hall

  5. #5
    SitePoint Wizard silver trophy
    Join Date
    Mar 2006
    Posts
    6,132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it drove me crazy for a few days, that was when the google bar first came out and a web search on it didnt yield much info

  6. #6
    SitePoint Enthusiast snorky's Avatar
    Join Date
    Jul 2003
    Location
    Great Northwet
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    On FireFox, I use the search plug-in, which allows me to select which search engine will do the search. From that plug-in I use Google + 38 engines which are more targeted.

    That "Google-on-steroids" bar does not mess with the appearance of form fields.

    It simply ROX. Take that, IE.

    Thanks again for the help.
    Snorky
    Bless the little children while they're still too young to hate.
    - Tom T. Hall


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •