SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Install successful but browser not recognising

    Hi
    I have successfully installed ruby on Linux and on running the command
    ruby script/server

    I get the message

    => Booting WEBrick...
    => Rails application started on http://0.0.0.0:3000
    => Ctrl-C to shutdown server; call with --help for options
    [2006-02-16 11:50:14] INFO WEBrick 1.3.1
    [2006-02-16 11:50:14] INFO ruby 1.8.2 (2004-12-25) [i686-linux]
    [2006-02-16 11:50:14] INFO WEBrick::HTTPServer#start: pid=11286 port=3000
    [2006-02-16 11:56:00] INFO going to shutdown ...
    [2006-02-16 11:56:00] INFO WEBrick::HTTPServer#start done.

    When I am going to http://127.0.0.1:3000 I dont see anything
    What am I doing wrong??
    Thanks
    San

  2. #2
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    When I go to http://127.0.0.1:3000 I can see the ruby installed page
    but when I go to my domain.com:3000 I dont see anything
    What might be the issue??
    SAn

  3. #3
    SitePoint Guru silver trophy Luke Redpath's Avatar
    Join Date
    Mar 2003
    Location
    London
    Posts
    794
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    First of all, try not to confuse Ruby and RubyOnRails. Ruby is just the language, what you are doing is running the script/server command that comes with RubyOnRails and it is the Rails installed page you are seeing.

    The server is running on your local machine so going to localhost:3000 (or 127.0.0.1:3000) will load up your Rails app. However, unless you've configured the DNS for your domain to point at your local machine then obviously going to yourdomain.com won't do anything.

    What are you actually trying to do, develop locally or deploy an app into production? I'm guessing the former.

  4. #4
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the reply
    <<What are you actually trying to do, develop locally or deploy an app into production? I'm guessing the former.>>>
    How do I deploy it for production

  5. #5
    SitePoint Wizard samsm's Avatar
    Join Date
    Nov 2001
    Location
    Atlanta, GA, USA
    Posts
    5,011
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by chanani_s
    How do I deploy it for production
    1. Find a web host that supports Rails.
    2. Follow their instructions on how to set up a Rails site.
    Using your unpaid time to add free content to SitePoint Pty Ltd's portfolio?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •