SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: RoR with cPanel

Hybrid View

  1. #1
    + platinum's Avatar
    Join Date
    Jun 2001
    Location
    Adelaide, Australia
    Posts
    6,441
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    RoR with cPanel

    Anyone set it up yet with no probs?

    I followed a guide on the RoR wiki and it sorta works, but everytime I actually try and run a test app I get

    Application error
    Rails application failed to start properly

    any ideas? using fastCGI... this is my httpd.conf entry as it is

    <IfModule mod_fastcgi.c>
    FastCgiIpcDir /tmp/fcgi_ipc/
    AddHandler fastcgi-script .fcgi
    FastCgiWrapper On
    </IfModule>

  2. #2
    SitePoint Wizard samsm's Avatar
    Join Date
    Nov 2001
    Location
    Atlanta, GA, USA
    Posts
    5,011
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You probably want to dig into rails_site/log/production.log to see a more specific error.
    Using your unpaid time to add free content to SitePoint Pty Ltd's portfolio?

  3. #3
    + platinum's Avatar
    Join Date
    Jun 2001
    Location
    Adelaide, Australia
    Posts
    6,441
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, it's empty unfortunatly - even the "Welcome to Rails" screen, clicking on the environmental variables gives the same error. Very strange!

  4. #4
    SitePoint Wizard samsm's Avatar
    Join Date
    Nov 2001
    Location
    Atlanta, GA, USA
    Posts
    5,011
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    A 500 Error should show up in one of those logs.

    Have log and public been 775ed?

    Do the dispatch files run on a command line?
    Using your unpaid time to add free content to SitePoint Pty Ltd's portfolio?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •