SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Jan 2006
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Image display query

    As a relative newbie to all this website design, this may be a basic query for some of you.

    I have a MYSQL database that holds various details including logos from some of our partners. One or two of these lines however do not have a logo file contained in the database. When these lines are displayed on the webpage then in Firefox everything appears to be ok, however, in IE this is not the case, where the text field in the database is blank then IE displays a placeholder, not what is required.

    Anyone got ways of dealing with this, or is it just yet another IE bug.

  2. #2
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by nmutimer
    I have a MYSQL database that holds various details including logos from some of our partners.
    is this actually the logo (in a BLOB field)? or is it just a URL to a logo?
    ...where the text field in the database is blank then IE displays a placeholder, not what is required.
    sounds like you're using a URL.

    if so this is not a problem with mysql, but with your webpage. if there is no URL displayed, then your application either needs to not display the image tag or provide an alternate default image URL.

  3. #3
    SitePoint Member
    Join Date
    Jan 2006
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by longneck
    is this actually the logo (in a BLOB field)? or is it just a URL to a logo?

    sounds like you're using a URL.

    if so this is not a problem with mysql, but with your webpage. if there is no URL displayed, then your application either needs to not display the image tag or provide an alternate default image URL.
    Longneck, thanks for the response, i agree, the problem is not with MySql, which is why i had posted this in the graphics section, but someone kindly moved it here.

    You are right, the database contains the relative url, it is only if this filed is blank that the problems occurs, i have currently solved it by linking to a spacer image, rather than leaving it blank.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •