SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    Non-Member jake4974's Avatar
    Join Date
    Jan 2006
    Location
    Down the road, it's where I'll always be
    Posts
    357
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Nonexistent fields showing up

    It is strange, I have this field in a table thats not cooperating.
    I deleted it using the phpmyadmin interface, but it still showed up.
    So I tried deleting it with straight sql, and got a nonexistent field error, but it still returns in select results.
    I'm stumped, any ideas?
    Sorry, row that is not cooperating.
    Last edited by jake4974; Jan 27, 2006 at 10:58.

  2. #2
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    try running a repair on your table.

  3. #3
    Non-Member jake4974's Avatar
    Join Date
    Jan 2006
    Location
    Down the road, it's where I'll always be
    Posts
    357
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Weirdness, still showing up. Oh well, fortunately I can just ignore it. Pretty weird though.

    Btw, thanks longneck

  4. #4
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    can you post the create table for the table in question, along with the SQL command you used to delete the column?

  5. #5
    Non-Member jake4974's Avatar
    Join Date
    Jan 2006
    Location
    Down the road, it's where I'll always be
    Posts
    357
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry, that original post and it's title are actually pretty misleading.
    It is a row of data I cannot delete for some reason, seems to drop/add columns with no problem.
    Originally I had 7 certain rows in one table, I can't remember why, but I needed to actually split these 7 into separate tables, so I just copied the table and deleted unnecessary rows. This one row would not delete "correctly" in many of the tables. If I just recreate the structure an insert only the necessary data, it's all good.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •