SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Zealot trigger8's Avatar
    Join Date
    Nov 2000
    Location
    Dallas, TX
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Passing Problem in Netscape

    I used urlencode() in my script so that when I pass the variable it can be read by the next page. I was trying to pass 'Soap Operas - Day'

    The space was replaced by %20 automatically and works fine in IE:
    http://domain.com/script.php?term=So...eras%20-%20Day

    But not in Netscape. This is how it looked like in the Netscape address bar:
    http://domain.com/script.php?term=Soap Operas - Day

    where it is supposed to look like the one in IE.

    Is this an incompatibility issue?
    Last edited by trigger8; Aug 30, 2001 at 10:49.
    Trigger8

    **************************
    I killed a 6-pack just to watch it die!

  2. #2
    SitePoint Addict
    Join Date
    Apr 2001
    Location
    None
    Posts
    254
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What Netscape version are you using? I'm using urlencode() as well on my sites, and everything works just fine in both, Netscape and IE.

  3. #3
    SitePoint Zealot trigger8's Avatar
    Join Date
    Nov 2000
    Location
    Dallas, TX
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm using Netscape 4.7.
    Trigger8

    **************************
    I killed a 6-pack just to watch it die!

  4. #4
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My guess is its your implementation of urlencode() that is causing the problem. Can we see the code please? I have Netscape 4.7 and it works fine for me. Have a look here.

    Example:
    http://www.irq11.com/~louie/spftest.php

    Source Code:
    http://www.irq11.com/~louie/spftest.phps
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  5. #5
    SitePoint Zealot trigger8's Avatar
    Join Date
    Nov 2000
    Location
    Dallas, TX
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Is there anything wrong with this??
    <A HREF="<? echo"$PHP_SELF";?>?term=<?php echo $heading->Fields("heading")?>">Link</a>
    Trigger8

    **************************
    I killed a 6-pack just to watch it die!

  6. #6
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Where are you urlencoding this?
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  7. #7
    SitePoint Zealot trigger8's Avatar
    Join Date
    Nov 2000
    Location
    Dallas, TX
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks guys! it's fixed!
    Trigger8

    **************************
    I killed a 6-pack just to watch it die!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •