Running Ruby on WAMP configuration.

Just installed Ruby and I CAN get the "Congratulation, you've put Ruby on Rails!" page to appear when going to the virtual host I appropriated for it. I generated a blog controller and when trying to test it I get the following error:

Application error
Rails application failed to start properly

I cleared the apache error log, restarted the web server and tried again. Here is the resulting error:

[Tue Nov 29 10:22:50 2005] [notice] Parent: Received restart signal -- Restarting the server.
[Tue Nov 29 10:22:50 2005] [notice] Child 5496: Exit event signaled. Child process is ending.
[Tue Nov 29 10:22:50 2005] [notice] Apache/2.0.54 (Win32) mod_fastcgi/2.4.2 PHP/5.0.3 configured -- resuming normal operations
[Tue Nov 29 10:22:50 2005] [notice] Server built: Apr 16 2005 14:25:31
[Tue Nov 29 10:22:50 2005] [notice] Parent: Created child process 2040
[Tue Nov 29 10:22:50 2005] [notice] Child 2040: Child process is running
[Tue Nov 29 10:22:50 2005] [notice] FastCGI: process manager initialized
[Tue Nov 29 10:22:51 2005] [notice] Child 2040: Acquired the start mutex.
[Tue Nov 29 10:22:51 2005] [notice] Child 5496: Released the start mutex
[Tue Nov 29 10:22:51 2005] [notice] Child 2040: Starting 250 worker threads.
[Tue Nov 29 10:22:52 2005] [notice] Child 5496: Waiting for 250 worker threads to exit.
[Tue Nov 29 10:22:52 2005] [notice] Child 5496: All worker threads have exited.
[Tue Nov 29 10:22:53 2005] [notice] Child 5496: Child process is exiting
[Tue Nov 29 10:23:34 2005] [warn] FastCGI: (dynamic) server "D:/htdocs/test/public/dispatch.fcgi" started (pid 2304)
[Tue Nov 29 10:23:37 2005] [error] [client 127.0.0.1] (OS 109)The pipe has been ended. : FastCGI: comm with server "D:/htdocs/test/public/dispatch.fcgi" aborted: GetOverlappedResult() failed
[Tue Nov 29 10:23:37 2005] [warn] FastCGI: (dynamic) server "D:/htdocs/test/public/dispatch.fcgi" (pid 2304) terminated with exit with status '0'
[Tue Nov 29 10:23:37 2005] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "D:/htdocs/test/public/dispatch.fcgi"
[Tue Nov 29 10:23:39 2005] [warn] FastCGI: (dynamic) server "D:/htdocs/test/public/dispatch.fcgi" restarted (pid 4244)
can anyone help me resolve this?