SitePoint Sponsor

User Tag List

Results 1 to 12 of 12
  1. #1
    SitePoint Addict
    Join Date
    Jun 2001
    Location
    Malaysia
    Posts
    352
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    installing PHP on Linux issues

    hey guys..

    I've got a problem during a "make install" portion when installing PHP on a Linux Redhat machine.

    Am trying to install PHP4.0.6 on a HP10.20 with Apache 1.3.9.

    MYSQL is preloaded from PHP4.0.6

    Here's the error message:

    error produced by make install
    ( i did not use our existing mysql instead using the prepackaged mysql libraries from PHP4)

    wcchan@pdchp7> make install
    Making install in Zend
    Making install in main
    Making install in ext
    Making install in mysql
    Making install in libmysql
    Making install in pcre
    Making install in pcrelib
    Making install in posix
    Making install in session
    Making install in standard
    Making install in xml
    Making install in expat
    Making install in xmltok
    Making install in xmlparse
    Making install in sapi
    Making install in apache
    Making install in TSRM
    Making install in regex
    Making install in .
    /stor/www/server/apache_1.3.9/php-4.0.6/build/shtool mkdir -p "/stor/www/server/apache_1.3.9/libexec" && /stor/www/server/apache_1.3.9/bin/apxs -S LIBEXECDIR="/stor/www/server/apache_1.3.9/libexec" -i -a -n php4 libs/libphp4.sl
    apxs:Error: file libs/libphp4.sl is not a shared object
    *** Error exit code 1

    Stop.

    Any ideas?


  2. #2
    SitePoint Addict
    Join Date
    Jun 2001
    Location
    Malaysia
    Posts
    352
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hey guys...

    I've tried a different approach to this by the following method:

    Using HP10.20 Apache1.3.9 with separate mySQL on a HP11.0 system.

    Here's the generated error:

    PHP4.0.6
    Reference from: /stor/hp700_ux100/usr/local/mysql-3.23.25-beta-hp-hpux11.00-hppa2.0w/lib/libmysqlclient.a(str2int.o)(0xadc)
    /bin/ld: Data Linkage Table (+z) overflow in file /stor/hp700_ux100/usr/local/mysql-3.23.25-beta-hp-hpux11.00-hppa2.0w/lib/libmysqlclient.a(str2int.o) - use +Z option to recompile
    Reference from: /stor/hp700_ux100/usr/local/mysql-3.23.25-beta-hp-hpux11.00-hppa2.0w/lib/libmysqlclient.a(str2int.o)(0xaec)
    /bin/ld: Data Linkage Table (+z) overflow in file /stor/hp700_ux100/usr/local/mysql-3.23.25-beta-hp-hpux11.00-hppa2.0w/lib/libmysqlclient.a(str2int.o) - use +Z option to recompile
    Reference from: /stor/hp700_ux100/usr/local/mysql-3.23.25-beta-hp-hpux11.00-hppa2.0w/lib/libmysqlclient.a(str2int.o)(0xafc)
    /bin/ld: Data Linkage Table (+z) overflow in file /stor/hp700_ux100/usr/local/mysql-3.23.25-beta-hp-hpux11.00-hppa2.0w/lib/libmysqlclient.a(str2int.o) - use +Z option to recompile
    Reference from: /stor/hp700_ux100/usr/local/mysql-3.23.25-beta-hp-hpux11.00-hppa2.0w/lib/libmysqlclient.a(str2int.o)(0xb0c)
    /bin/ld: Invalid fixups exist
    collect2: ld returned 1 exit status
    *** Error exit code 1

    Any ideas?



  3. #3
    You talkin to me? Anarchos's Avatar
    Join Date
    Oct 2000
    Location
    Austin, TX
    Posts
    1,438
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry but I can't help you there. I have never been able to compile PHP or Apache on linux, I always get seg faults during the build.
    ck :: bringing chris to the masses.

  4. #4
    SitePoint Addict
    Join Date
    Jun 2001
    Location
    Malaysia
    Posts
    352
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmmm... s'ok.

    Anyone else care to gimme a hand?

  5. #5
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hey can we see your configure line? I am curious to see what extensions you are trying to compile in. Also what is the path to MySQL on your system?
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  6. #6
    SitePoint Addict
    Join Date
    Jun 2001
    Location
    Malaysia
    Posts
    352
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    here's how I did it, Not quite sure what exactly you wanted, but here's the result. I tried both methods... and I still faced the same error....


    (preloaded Mysql from PHP)
    HP10.20 - ./configure --with-mysql --with-apxs=/stor/www/server/apache_1.3.9/bin/apxs

    (with own Mysql)
    HP10.20 - ./configure --with-mysql=/usr/local/mysql --with-apxs=/stor/www/server/apache_1.3.9/bin/apxs

  7. #7
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am not very good with HP-UX, in fact I have 0 experience with it. I have however compiled PHP and MySQL a few times on linux. One thing I find is that I need to just use --with-mysql=/usr/local

    Also maybe this link can shed some light on it.
    http://www.php.net/manual/en/install.hpux.php
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  8. #8
    SitePoint Addict
    Join Date
    Jun 2001
    Location
    Malaysia
    Posts
    352
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I tried that too, Freddy, but it didn't work out. I've been at this for over 2 weeks, without a successful solution....

  9. #9
    SitePoint Addict
    Join Date
    Jun 2001
    Location
    Malaysia
    Posts
    352
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    new update

    Other attempt -
    Using Apache on HP11....
    Own MYSQL.....

    during " configure " process, the following error is seen:

    wcchan@pdchp54> ./configure --with-mysql=/usr/local/mysql
    --with-apxs=/stor/www/server/hp11/apache/sbin/apxs

    creating cache ./config.cache
    checking for a BSD compatible install... /usr/intel/bin/ginstall -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... yes
    checking for working aclocal... missing
    checking for working autoconf... found
    checking for working automake... missing
    checking for working autoheader... found
    checking for working makeinfo... found
    Updated php_version.h
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking host system type... hppa2.0w-hp-hpux11.00
    checking for gawk... gawk
    checking for bison... bison -y
    checking bison version... 1.25 (ok)
    checking for gcc... gcc
    checking whether the C compiler (gcc ) works... no
    configure: error: installation or configuration problem: C compiler cannot
    create executables.

    Sigh.

  10. #10
    SitePoint Member
    Join Date
    Aug 2001
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay I have only compiled php and mysql a few times, but I did not use a --with-mysql line with php 4*. Somewhere I read (in the php docs) that php 4 did not nead that option. If I were you I would glance through the INSTALL or README file that you dled with php, it might have some tips for your setup. Also was apache installed with apxs? I had to recompile apache because apxs was not installed right last time. hope you can make since of that and that it is of some use to you...
    Microsoft’s Motto: Resistance is futile, you will be assimilated…

  11. #11
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Infintium,

    It appears the install can't find a valid gcc compiler. If you don't have one you'll need one, if you have one make sure the path to it is in your path.
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  12. #12
    SitePoint Addict
    Join Date
    Jun 2001
    Location
    Malaysia
    Posts
    352
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks guys..

    I've given up on this.. and switched to a Windoze PC... hope things work out fine on this new box...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •