SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Guru DenverDave's Avatar
    Join Date
    Feb 2001
    Location
    Denver, Colorado
    Posts
    630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PHP upgrade 4.0.4 to 4.0.6

    WindowsME, Apache, CGI, MySql, PHP 4.0.6, running locally

    I upgraded from PHP 4.0.4 to 4.0.6 and now PHP.exe insists on accessing the internet though my firewall whenever a connection to a local mySQL database is made. 4.0.4 does not have this problem and when I switch the old 4.0.4 PHP directory back into use - the problem goes away.

    I don't like programs accessing the internet without my permission and I am not always connected to the internet so the connection will fail when not connected. I wonder what the 4.0.6 php.exe is looking for that I am not providing.

    WindowsME, Apache, CGI, MySql, PHP 4.0.6 running locally (dropping back to 4.0.4 to avoid the problem). From a Google search it looks like others may be having this problem, but is there a solution? Have others experienced this on this forum?

    Thanks - Dave

  2. #2
    You talkin to me? Anarchos's Avatar
    Join Date
    Oct 2000
    Location
    Austin, TX
    Posts
    1,438
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have 4.0.6/Apache/MySQL and it doesn't do that, you should look over your php.ini. To what ip/host is it connecting?
    ck :: bringing chris to the masses.

  3. #3
    Mlle. Ledoyen silver trophy seanf's Avatar
    Join Date
    Jan 2001
    Location
    UK
    Posts
    7,168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ZoneAlarm will think that PHP is accessing the Internet even though it is connecting to localhost

    Sean
    Harry Potter

    -- You lived inside my world so softly
    -- Protected only by the kindness of your nature

  4. #4
    SitePoint Guru DenverDave's Avatar
    Join Date
    Feb 2001
    Location
    Denver, Colorado
    Posts
    630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Situation seems to have gone away

    (sigh) PHP4.0.6 php.exe seems to have stopped trying to access the internet and I can run Apache / PHP and MySql with my Internet connection closed.

    Thanks for all the help from everyone who answered me, but let's drop for now and spend time on other things.

    Thank you for you help.
    Dave


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •