I need to dig up the exact error message, but I can't use gems behind my uni's proxy on Windows. I've added HTTP_PROXY in the environment, and I've tested this works with....

require 'open-uri'
open('http://google.com', 'r').read

and all is well, however gems seems to still fail to see the proxy settings from the looks of it. I'll copy and paste the error later if after a lecture