SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Nov 2005
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    newbie teething trouble on macos X

    Hi,
    I'm an experience perl programmer who has decided to give ruby a try.
    I'm running on MacOS 10.4.

    I have ruby installed from fink (i.e. in /sw) and I have Tcl/Tk Aqua which installs in /Library and there in lies the problem.

    I have a trivial program that uses tk but ruby failes to find the tcl.init file. The error I get show it searching for tcl in /sw. I tried putting in some sym links to /Library but this then brings up the error:

    bluebottle:~/contacts rful011$ ruby contacts-maint
    /sw/lib/ruby/1.8/tk.rb:677:in `initialize': invalid command name "tcl_findLibrary" (RuntimeError)
    from /sw/lib/ruby/1.8/tk.rb:677:in `new'
    from /sw/lib/ruby/1.8/tk.rb:677
    from contacts-maint:3:in `require'
    from contacts-maint:3

    should I simply give up on tcl/aqua and install tcl from fink or is there a way to get ruby to play nicely with tcl/aqua?

    Cheers, Russell Fulton

  2. #2
    SitePoint Guru
    Join Date
    May 2003
    Location
    virginia
    Posts
    988
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm, I don't know anything about fink etc., but what I did was to just get gems, install it and then install rails. I'm running 10.4.3

    -matt


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •