SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Oct 2005
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Login failed for user 'test'

    Hi experts:

    I have a simple ASP code that i am trying to use in order to get records from a database in SQLserver 2000 and display it in html format.

    I named the file index.asp and placed it in the home directrory for IIS. When i type in http://localhost/index.asp, i get 500 errors. On viewing the IIS logs, i am noticing the following errors:

    2005-10-31 20:05:16 W3SVC1 127.0.0.1 GET /index.asp |47|80040e4d|Login_failed_for_user_'test'

    After searching on the internet, I have already checked "SQL Server and Windows" authentication in SQL Server security.

    here is the code that i am using to connect to the database:

    Set db = Server.CreateObject("ADODB.Connection")
    db.Open "Provider=SQLOLEDB;Data Source=Machine1;" _
    & "Initial Catalog=databasename;User Id=test;Password=test;" _
    & "Connect Timeout=15;Network Library=dbmssocn;"

    User 'test' is a domain user and has dbo permissions to the database i am trying to access.

    Can anyone give me some advice as to how i can get this working?

    thanks
    trev

  2. #2
    Afrika
    Join Date
    Jul 2004
    Location
    Nigeria
    Posts
    1,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  3. #3
    Afrika
    Join Date
    Jul 2004
    Location
    Nigeria
    Posts
    1,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i would also advice you to go to tools>> internet options >> advanced tab and scroll down to browsing and uncheck the show friendly user http errors, so you would see the error in your browser and not your logs

    hope this helps


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •