SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Addict n0vembr's Avatar
    Join Date
    Jun 2005
    Posts
    219
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    unable to listen for connections on address 0.0.0.0:80

    hello there..
    im trying to install an apache server in my pc (win xp pro)
    but i have encountered this error:

    (OS 10022)The invalid argument was offered. : make_sock: unable to listen for connections on address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    i have tried changing the port used to 8080、8083 among others..but still in vain.
    i have run netstat -an. here's the result:


    C:\Documents and Settings\ml>netstat -an

    Active Connections

    Proto Local Address Foreign Address State
    TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
    TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
    TCP 0.0.0.0:443 0.0.0.0:0 LISTENING
    TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
    TCP 0.0.0.0:1027 0.0.0.0:0 LISTENING
    TCP 0.0.0.0:1029 0.0.0.0:0 LISTENING
    TCP 0.0.0.0:1031 0.0.0.0:0 LISTENING
    can somebody help me please??? i have used up my entire afternoon trying to figure this one out...i need your helpppp

    many thanks in advance
    foLLow your bLiss

  2. #2
    Can we go to a 48 hour day?
    Join Date
    May 2002
    Location
    MI
    Posts
    906
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    local host is not 0.0.0.0 it's 127.0.0.1. Change your setting to 127.0.0.1 instead of 0.0.0.0 and you should be fine.
    mitechie.com
    "Techies just think a little differently
    ...at least that is what they keep telling me."

  3. #3
    SitePoint Addict n0vembr's Avatar
    Join Date
    Jun 2005
    Posts
    219
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by deuce868
    local host is not 0.0.0.0 it's 127.0.0.1. Change your setting to 127.0.0.1 instead of 0.0.0.0 and you should be fine.
    i already tried that...still the same error... :S
    foLLow your bLiss

  4. #4
    Can we go to a 48 hour day?
    Join Date
    May 2002
    Location
    MI
    Posts
    906
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you restart the servers? The error should have at least changed to say use 127.0.0.1 or else you missed a setting with the 0.0.0.0 stuff somewhere.
    mitechie.com
    "Techies just think a little differently
    ...at least that is what they keep telling me."

  5. #5
    SitePoint Addict n0vembr's Avatar
    Join Date
    Jun 2005
    Posts
    219
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by deuce868
    Did you restart the servers? The error should have at least changed to say use 127.0.0.1 or else you missed a setting with the 0.0.0.0 stuff somewhere.
    yes, i did...and it did say i was using 127.0.0.1...
    foLLow your bLiss

  6. #6
    SitePoint Author silver trophybronze trophy
    wwb_99's Avatar
    Join Date
    May 2003
    Location
    Washington, DC
    Posts
    10,625
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Do you have IIS running? Or some other server listening on port 80? That is the error I usually get when adding Apache to a pre-existing server.

  7. #7
    SitePoint Addict n0vembr's Avatar
    Join Date
    Jun 2005
    Posts
    219
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by wwb_99
    Do you have IIS running? Or some other server listening on port 80? That is the error I usually get when adding Apache to a pre-existing server.

    hi wwb_99..thanks for your time..sorry for the very delayed reply..
    yes i do have an IIS running.. how do i disable this? :S
    but ive already tried other ports..still got stuck with the same error...
    foLLow your bLiss

  8. #8
    SitePoint Enthusiast
    Join Date
    Mar 2005
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0.0.0.0 mean listen all interfaces, so its surely ok
    But as for IIS try to check running Services from Computer management, probably u can stop or disable IIS from there.
    Alternatively u can bind Apache to other port like 8080, u need to set "Listen 8080" in apache config file (search for "Listen 80" string), path looks like c:\Program Files\Apache Group\Apache2\conf\httpd.conf
    website url will be http://127.0.0.1:8080/ in that case

    Hope its clear enough


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •