SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Wizard jumpthru's Avatar
    Join Date
    Apr 2000
    Location
    Los Angeles, California
    Posts
    1,008
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Questoin about fresh install of mysql

    I have a fresh install of mysql and it works perfect, except that when I start up mysql it gives me this error message

    Code:
    Can't initialize InnoDB as 'innodb_data_file_path' is not set
    But it still loads fine.

    After reading a little, I found that there are different types of databases you can use in mysql. Which one is the best to use? Which one is the 'normal' one you use when you create a new database using phpMyAdmin or on Unix? What if I dont want to use the InnoDB type of database? Do I still have to set that variable in my.cnf to get rid of that error message? Thanks.

  2. #2
    You talkin to me? Anarchos's Avatar
    Join Date
    Oct 2000
    Location
    Austin, TX
    Posts
    1,438
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You shouldn't be getting that error, something went wrong or was done incorrectly. And there obviously isn't a "best" database (actually you mean table) to use or else why would they include the worse ones? Different table types are optimized for different applications: read through these descriptions: http://www.mysql.com/doc/T/a/Table_types.html
    ck :: bringing chris to the masses.

  3. #3
    SitePoint Wizard jumpthru's Avatar
    Join Date
    Apr 2000
    Location
    Los Angeles, California
    Posts
    1,008
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yea your right, tables...

    What did I do wrong? I just installed it normally...I wasn't able to run scripts/mysql_install_db though, because I could never find it...

    Any ideas?

  4. #4
    SitePoint Member
    Join Date
    Jul 2001
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What's your system configration?

    Did you use RPM or you had to compile the source?

    Give us details.
    Rick Yang
    rickyang@earthlink.net
    Linux, Apache, Perl, PHP, Linux/Web Security Consultant
    http://www.supportsonline.com

  5. #5
    SitePoint Wizard johnn's Avatar
    Join Date
    Mar 2001
    Location
    Southern California, USA
    Posts
    1,181
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can't initialize InnoDB as 'innodb_data_file_path' is not set
    Here's the info that I found at phpbuilder.com
    FROM: mysql.com
    DATE: 05/29/2001 11:57:01
    SUBJECT: Explanations about the start up of MySQL 3.23.38 on Windows
    Hi!

    We have noticed some mails posted by Windows users having problem
    in the first start of mysqld.exe on Windows platforms. Then, below
    the explanations how to avoid the problems reported:

    1- According with our MySQL-Max download page is noticed that the
    regular distribution 3.23.38, contains the MySQL-Max stuff.
    The MySQL-Max stuff has additional features:

    - Support for transactions with two types of tables: InnoDB and
    BDB.
    - Support for symbolic links to have databases on another place
    than the default one.
    - The servers which have the MySQL-Max support are:

    mysqld.exe
    mysqld-max.exe
    mysqld-max-nt.exe

    2- When the MySQL-Max servers are started, the InnoBD routines tries
    to found the paths for its data and log files. When aren't specified
    that data on the \my.cnf or \WindDir\my.ini file, the server launches
    the following warning message:
    Can't initialize InnoDB as 'innodb_data_file_path' is not set

    The above means that the InnoDB tables are disabled, however the
    server is ready for the others tables.

    C:\mysql\bin>mysql
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 1 to server version: 3.23.38-max

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer

    mysql> show variables like "have_innodb";
    +---------------+----------+
    | Variable_name | Value |
    +---------------+----------+
    | have_innodb | DISABLED |
    +---------------+----------+
    1 row in set (0.05 sec)

    If you don't want the InnoDB tables support and to avoid the above
    warning message, you could create the \my.cnf (jumpthru, I place the my.cnf in directory C:\) or \WindDir\my.ini file
    and add the below variable:

    [mysqld]
    skip-innodb

    Otherwise if you want the InnoDB tables support, you need to read in
    our Manual how to prepare the configuration file. Below the
    preliminaries instructions:

    - Create the log and data directories, for example: c:\ibdata and
    c:\iblogs.
    - Create the configuration file and edit the variables according
    with the Manual instructions. Notice that the sizes of the files
    can't exceed 2000M.
    - Start the server and you will see, the messages that InnoDB are
    creating the files:

    C:\mysql\bin>mysqld-max --standalone
    InnoDB: The first specified data file c:\ibdata\ibdata1 did not
    exist:
    InnoDB: a new database to be created!
    InnoDB: Setting file c:\ibdata\ibdata1 size to 26214400
    InnoDB: Database physically writes the file full: wait...
    InnoDB: Data file c:\ibdata\ibdata2 did not exist: new to be created
    InnoDB: Setting file c:\ibdata\ibdata2 size to 38797312
    InnoDB: Database physically writes the file full: wait...
    InnoDB: Data file c:\ibdata\ibdata3 did not exist: new to be created
    InnoDB: Setting file c:\ibdata\ibdata3 size to 104857600
    InnoDB: Database physically writes the file full: wait...
    InnoDB: Data file c:\ibdata\ibdata4 did not exist: new to be created
    InnoDB: Setting file c:\ibdata\ibdata4 size to 314572800
    InnoDB: Database physically writes the file full: wait...
    InnoDB: Log file c:\iblogs\ib_logfile0 did not exist: new to be
    created
    InnoDB: Setting log file c:\iblogs\ib_logfile0 size to 5242880
    InnoDB: Log file c:\iblogs\ib_logfile1 did not exist: new to be
    created
    InnoDB: Setting log file c:\iblogs\ib_logfile1 size to 5242880
    InnoDB: Log file c:\iblogs\ib_logfile2 did not exist: new to be
    created
    InnoDB: Setting log file c:\iblogs\ib_logfile2 size to 5242880
    InnoDB: Started

    Notice that you can to start the server as service on WinNT and
    Win2k OSs. The server should be used is the mysqld-max-nt.exe

    3- The mysqld.exe on Win9x

    How mentioned above, this server has the Max stuff, however on the
    3.23.38 distribution was compiled with the InnoDB library with a
    pre-processor define option for NT platform, which cause a handle
    exception when tries to create the data and log files.
    If you want to use InnoDB tables on Win9x, use instead the mysqld-max.exe
    server.
    Also this server doesn't has the symbolic link support.
    Those problem already are fixed and in the next release, the mysqld.exe
    should be able to run on Win9x with the InnoDB and symbolic link supports.

    4- Using Symbolic Links

    To use this support we explains it with a sample:
    Do you want a database called mylink on the d:\mydata directory.
    First create on \mysql\data directory a file called mylink.sym.
    Edit this file with the text: d:\mydata\mylink\
    Notice the trailing backlash in the end of the path. This is important
    only in the 3.23.38 distribution. In the next MySQL release will added
    code to handle a path like: d:\mydata\mylink
    Create the directory d:\mydata\mylink
    Add to configuration file the variable use-symbolic-links. If you
    aren't starting the server as service you should use the
    --use-symbolic-links as parameter in the command line.

    Regards,
    Miguel

  6. #6
    SitePoint Wizard jumpthru's Avatar
    Join Date
    Apr 2000
    Location
    Los Angeles, California
    Posts
    1,008
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, that helped me very much!

    One more question...

    Does anyone know who to make a blank line usin the echo command in a .bat file?

  7. #7
    SitePoint Wizard johnn's Avatar
    Join Date
    Mar 2001
    Location
    Southern California, USA
    Posts
    1,181
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    echo.

  8. #8
    SitePoint Wizard jumpthru's Avatar
    Join Date
    Apr 2000
    Location
    Los Angeles, California
    Posts
    1,008
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sweet! Thank you very much!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •