SitePoint Sponsor

User Tag List

Results 1 to 17 of 17
  1. #1
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Rails install hangs on Updating Gem Source index for: http://gems.rubyforge.org

    I can't remotely install rails on XP.

    after I type "gem install rails" into the cmd, it hangs on "Updating Gem Source index for: http://gems.rubyforge.org". I've been searching the net for a solution but can't find one. Others seem to have the problem but no solution I've found works. Anyone familiar with this problem?

  2. #2
    eschew sesquipedalians silver trophy sweatje's Avatar
    Join Date
    Jun 2003
    Location
    Iowa, USA
    Posts
    3,749
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are you behind a proxy server? IIRC, the work around was to download by hand and install the file locally.
    Jason Sweat ZCE - jsweat_php@yahoo.com
    Book: PHP Patterns
    Good Stuff: SimpleTest PHPUnit FireFox ADOdb YUI
    Detestable (adjective): software that isn't testable.

  3. #3
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by sweatje
    Are you behind a proxy server? IIRC, the work around was to download by hand and install the file locally.
    I figured this was a possible solution. But I'm clueless as to how to actually do this. I've downloaded the .gem and the .zip from rubyonrails.org. I don't know where to go after that.

  4. #4
    eschew sesquipedalians silver trophy sweatje's Avatar
    Join Date
    Jun 2003
    Location
    Iowa, USA
    Posts
    3,749
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    http://docs.rubygems.org/read/chapter/10#page33
    Quote Originally Posted by doc
    2.9 gem install -- Installing a gem

    gem install will install the named gem. It will attempt a local installation (i.e. a .gem file in the current directory), and if that fails, it will attempt to download and install the most recent version of the gem you want.
    Looks like just dump it in the current directory and do gem install NAME
    Jason Sweat ZCE - jsweat_php@yahoo.com
    Book: PHP Patterns
    Good Stuff: SimpleTest PHPUnit FireFox ADOdb YUI
    Detestable (adjective): software that isn't testable.

  5. #5
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So I would have to manually fulfill the dependencies?

    It gives an error saying I need rake 0.5.3

  6. #6
    eschew sesquipedalians silver trophy sweatje's Avatar
    Join Date
    Jun 2003
    Location
    Iowa, USA
    Posts
    3,749
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yep, or maybe mess around with specifying the proxy info yourself?

    Code:
      Common Options:
            --source URL                 Use URL as the remote source for gems
        -p, --[no-]http-proxy [URL]      Use HTTP proxy for remote operations
    Jason Sweat ZCE - jsweat_php@yahoo.com
    Book: PHP Patterns
    Good Stuff: SimpleTest PHPUnit FireFox ADOdb YUI
    Detestable (adjective): software that isn't testable.

  7. #7
    SitePoint Addict Brak's Avatar
    Join Date
    Jul 2004
    Location
    Central Coast, CA
    Posts
    321
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I know this sounds stupid - but did you give it time? It takes about 30-45s to update the gem source index. It may seem like it hangs, but it's working.
    Studio Rockstar's Blog - A journey to quitting the dayjob.

  8. #8
    SitePoint Zealot
    Join Date
    Nov 2004
    Location
    Yakima WA.
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You are experiencing the dreaded firewall syndrome on XP. If you have ZoneAlarm installed or a few of the other similar firewalls, these programs interfere with the way that ruby accesses sockets on a windows system. It won't help to just turn off the firewall either, you have to completely uninstall it. It sucks because you really need a firewall on Windows but I have seen this same problem on the rails mailing list at least 20 times. gem hangs at the same line you mentioned and the only way to fix it is to uninstall Zone Alarm or similar firewalls.

    Good Luck

  9. #9
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Brak
    I know this sounds stupid - but did you give it time? It takes about 30-45s to update the gem source index. It may seem like it hangs, but it's working.
    Gave it a couple hours.

  10. #10
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ezmobius1
    You are experiencing the dreaded firewall syndrome on XP. If you have ZoneAlarm installed or a few of the other similar firewalls, these programs interfere with the way that ruby accesses sockets on a windows system. It won't help to just turn off the firewall either, you have to completely uninstall it. It sucks because you really need a firewall on Windows but I have seen this same problem on the rails mailing list at least 20 times. gem hangs at the same line you mentioned and the only way to fix it is to uninstall Zone Alarm or similar firewalls.

    Good Luck
    Ok. I read on a site that ZoneAlarm could be the cause so I shut it down but still no luck. I guess I'll uninstall now and give it a go. I hope this works because I'm getting no where with the manual install.

  11. #11
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well that seems to have done the trick.

    Thanks to all.

  12. #12
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    One more problem to overcome and it seems I'll be able to get my hands wet.

    Webrick starts my app at http://0.0.0.0:3000

    The onlamp tut I'm reading says its supposed to start at the normal localhost address: http://127.0.0.1:3000

    I've tried going to both addresses to see if the application with run...neither works.

  13. #13
    throw me a bone ... now bonefry's Avatar
    Join Date
    Nov 2004
    Location
    Romania
    Posts
    848
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by joflow
    I can't remotely install rails on XP.

    after I type "gem install rails" into the cmd, it hangs on "Updating Gem Source index for: http://gems.rubyforge.org". I've been searching the net for a solution but can't find one. Others seem to have the problem but no solution I've found works. Anyone familiar with this problem?
    It happened to me too. I had ZoneAlarm and had to uninstall it to make it work.

  14. #14
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Any insight on this new issue I'm having?

  15. #15
    eschew sesquipedalians silver trophy sweatje's Avatar
    Join Date
    Jun 2003
    Location
    Iowa, USA
    Posts
    3,749
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have never run this on windows, so I can't really give any guidance.

    On Linux, it reports 0.0.0.0 but still does run on localhost:

    Code:
    sweatje@devweb script $ ruby server &
    [1] 8109
    sweatje@devweb script $ => Rails application started on http://0.0.0.0:3000
    => Ctrl-C to shutdown server; call with --help for options
    [2005-10-04 20:02:44] INFO  WEBrick 1.3.1
    [2005-10-04 20:02:44] INFO  ruby 1.8.2 (2004-12-25) [i686-linux]
    [2005-10-04 20:02:44] INFO  WEBrick::HTTPServer#start: pid=8109 port=3000
    
    sweatje@devweb script $ curl localhost:3000
    127.0.0.1 - - [04/Oct/2005:20:02:56 CDT] "GET / HTTP/1.1" 200 3156
    - -> /
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
       "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
      <title>Rails: Welcome on board</title>
      <style>
        body { background-color: #fff; color: #333; }
    The settings are actually in the server script, perhaps you could just tweak the address and the port and see if it runs.
    Jason Sweat ZCE - jsweat_php@yahoo.com
    Book: PHP Patterns
    Good Stuff: SimpleTest PHPUnit FireFox ADOdb YUI
    Detestable (adjective): software that isn't testable.

  16. #16
    SitePoint Zealot GWild's Avatar
    Join Date
    May 2005
    Location
    Colorado
    Posts
    159
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by joflow
    Any insight on this new issue I'm having?
    Hello.

    Try editing the

    c:\windows\system32\drivers\etc\hosts

    file, adding the line:

    0.0.0.0:3000 localhost

    Or, alternatively (which is what I did since 127.0.0.1 localhost is already in the hosts file, and to which J.E.S. alluded), you can edit the rails

    /script/server

    file, and change the options->ip setting to 127.0.0.1, and the ARGV.options->opts.on->default setting to 80 if your box doesn't like port 3000.

    For some reason my dev system was picky about port 3000, so I just set the default WEBRick port to 80. It works great now.

    -hth-
    Lang ist der weg und hart,
    das aus der hoelle fuehrt auf zum licht.


    My Site

  17. #17
    SitePoint Zealot
    Join Date
    Dec 2004
    Location
    virginia
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I tried changing ports to 80...still isn't working. Isn't 80 universally used by web browsers to surf the web? So shouldn't that port be open? So in that case it shouldn't be a port problem.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •