Well for me...I have just started coding in PHP not too long ago...So the backward compatibility isn't really something that I have personally had a problem in..I learned off of PHP5 and that's all that I have used so far. I find it pretty complete and really extensive..There are things that I haven't even come CLOSE to using.