SitePoint Sponsor

User Tag List

Results 1 to 11 of 11
  1. #1
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy pcfg_openfile: unable to check htaccess file

    Hi everbody,

    I've been struggling with this problem for a while now. I'm on a hosted root server with vhost setup, and the php-based Plex app "getting in the way", I think, but not sure.

    I can set up and get pages to display in subdirs of httpdocs, but not my bugzilla directory, where I have put an .htaccess file. When I try to access it, I get the following error. Based on research, I verified that permissions are correct on the .htaccess file, so I don't know why the file is not readable.

    /home/httpd/vhosts/nanswi.com/httpdocs/bugzilla-2.18.3/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    [root@u15158424 httpdocs]# ls -ltr .ht*
    -rw-r--r-- 1 root root 239 Sep 3 12:24 .htaccess

    [Tue Sep 13 00:17:27 2005] [crit] [client 61.7.137.152] (13)Permission denied: /home/httpd/vhosts/nanswi.com/httpdocs/bugzilla-2.18.3/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    [root@u15158424 httpdocs]# ls -ltr bugzilla-2.18.3/.htaccess*
    -rw-r--r-- 1 root root 239 Sep 12 09:51 bugzilla-2.18.3/.htaccessx
    [root@u15158424 httpdocs]#

    [root@u15158424 httpdocs]# ls -ltr | grep bugz
    lrwxrwxrwx 1 root apache 15 Sep 4 06:52 bugzilla -> bugzilla-2.18.3
    dr-xr--r-- 13 root apache 4096 Sep 13 00:17 bugzilla-2.18.3
    [root@u15158424 httpdocs]#

    I've tried a variety of things to see what's making this happen, but so far no luck. :-(

    I found an older post about the pcfg_openfile error, and updated the vhost section of my httpd.conf file to reflect that, but the error did not change, as has been typical of all my attempts!

    Please help!

  2. #2
    SitePoint Evangelist
    Join Date
    Aug 2005
    Posts
    512
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think this is the cause.
    dr-xr--r-- 13 root apache 4096 Sep 13 00:17 bugzilla-2.18.3

    Set 755 on this directory and test again.
    Freebie/DonationWare: check-these.info
    Custom solutions: Hostwick.com

  3. #3
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, for your suggestion extras,

    I have tried that before. Actually, my most recent experiment involved renaming .htaccess, so it can't be found - same error.

    I did chmod as you suggested, to check that out again (correct file name this time), and the error has not changed.

  4. #4
    SitePoint Evangelist
    Join Date
    Aug 2005
    Posts
    512
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How about FollowSymlinks ?
    Do you have Options +FollowSymlinks for the directories concerned?

    Also, your bugzilla dir doesn't have .htaccess.
    -rw-r--r-- 1 root root 239 Sep 12 09:51 bugzilla-2.18.3/.htaccessx
    You named it .htaccessx, so Apache should be trying to read the .htaccess of the upper dir up to document root.
    So I'd check .htaccess found in all of those directories.

    Another thing you can do.
    Remove/rename all .htaccess and test again.
    If you still get errors, maybe it's the permission of directories causing it.

    If you show httpd.conf, we may be able to spot the cause, too.

    Finally, when you test, are you reloading each page?
    So many people think they are testing the new changed version
    while they are getting old cached data ....
    Last edited by extras; Sep 13, 2005 at 09:07.
    Freebie/DonationWare: check-these.info
    Custom solutions: Hostwick.com

  5. #5
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    > Do you have Options +FollowSynmlinks for the directories concerned?

    Yes.

    Sorry for the .htaccessx in the post, in reality I had changed it to .htaccess, but copied the wrong line.

    -rw-r--r-- 1 ray apache 239 Sep 12 09:51 .htaccess

    I've tried renaming/removing, but I either get the reported error, or, one saying the the file can't be found, check directory permissions:

    lrwxrwxrwx 1 root apache 15 Sep 4 06:52 bugzilla -> bugzilla-2.18.3
    dr-xr--r-- 13 root apache 4096 Sep 13 03:10 bugzilla-2.18.3

    I've uploaded my httpd.conf file (with domain changed for security).

    I'm looking into how to get firefox to reload instead of cache. I usually see changes when I make the right edits, but it is certainly possible that I'm not seeing changes - but I check the log each time I refresh, and that's where I get the bad news. :-(

    Thanks again for your help.

    Lars
    Attached Files Attached Files

  6. #6
    SitePoint Evangelist
    Join Date
    Aug 2005
    Posts
    512
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by BugzillaKilla
    I've tried renaming/removing, but I either get the reported error, or, one saying the the file can't be found, check directory permissions:
    Please be more specific.
    It's important to know which setup + URL produced what kind of results,
    including error log out put.

    Often, we don't find the cause/solution when we don't gather enough data to cross check.
    And it's crucial in remote debugging like we are doing.

    lrwxrwxrwx 1 root apache 15 Sep 4 06:52 bugzilla -> bugzilla-2.18.3
    dr-xr--r-- 13 root apache 4096 Sep 13 03:10 bugzilla-2.18.3
    Didn't I rell you to set 755 on bugzilla-2.18.3 ?
    Why do you set it to 544?
    To access a file Apache needs 'x' (for the directory). 'r' allows directory browsing (like ls).

    I've uploaded my httpd.conf file (with domain changed for security).
    Maybe you can set loglevel to 'debug' to see if you get more info.
    I still think it's the permission of the directory.

    I'm looking into how to get firefox to reload instead of cache.
    It's F5 or reload button. Also, you can clear the cache by tool ->option.
    Freebie/DonationWare: check-these.info
    Custom solutions: Hostwick.com

  7. #7
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    First of all, thanks for your attention to this problem.

    >Didn't I rell you to set 755 on bugzilla-2.18.3 ?
    >Why do you set it to 544?

    Sorry, tried that and changed it back to what I'd seen elsewhere as I kept deugging. Forgot to change it back.

    -rw-r--r-- 1 root root 239 Sep 3 12:24 .htaccess

    Got the same error:

    [Tue Sep 13 12:39:37 2005] [crit] [client 61.7.141.138] (13)Permission denied: /home/httpd/vhosts/nanswi.com/httpdocs/bugzilla/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    Here's what happened when I eliminated .htaccess:

    [root@u15158424 httpdocs]# ls .ht*
    ls: .ht*: No such file or directory

    [Tue Sep 13 12:41:25 2005] [crit] [client 61.7.141.138] (13)Permission denied: /home/httpd/vhosts/nanswi.com/httpdocs/bugzilla/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    Same same.

    Debug level Changed:
    #LogLevel warn
    LogLevel debug

    Same error:

    [Tue Sep 13 12:46:08 2005] [crit] [client 61.7.141.138] (13)Permission denied: /home/httpd/vhosts/nanswi.com/httpdocs/bugzilla/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    I have been wondering about the first of the two error lines below, but none of my web searching has pointed to this as being related. Since I can access non-bugzilla directories I've discounted it.

    [Tue Sep 13 12:45:37 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Tue Sep 13 12:45:37 2005] [debug] ssl_engine_init.c(754): Configuring RSA server private key

    >I still think it's the permission of the directory.

    I'd been wondering about that.

    [root@u15158424 httpdocs]# ls -ltr | grep bug
    lrwxrwxrwx 1 root apache 15 Sep 4 06:52 bugzilla -> bugzilla-2.18.3
    dr-xr--r-- 13 root apache 4096 Sep 13 03:10 bugzilla-2.18.3

    Still not clear on how to change permissions on aliases. :-(

  8. #8
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oh, yeah, you asked for play by play - what changes netted which results.

    I'll work on that.

    In the meantime, any clues found in my httpd.conf will be appreciated.

    All along, I've been concerned that there is a php/Plex issue affecting this, not to mention the issue of running cgi outside of the defined cgi space. I've successfully set up Bugzilla on my redhat RH9 localhost environment, no plex of vhost involved.

  9. #9
    SitePoint Evangelist
    Join Date
    Aug 2005
    Posts
    512
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You still have 544 ....
    dr-xr--r-- 13 root apache 4096 Sep 13 03:10 bugzilla-2.18.3

    You just need to do this (at the directory above it)
    chmod 755 bugzilla-2.18.3

    Or with absolute path:
    chmod 755 /path-to/bugzilla-2.18.3

    Permission of symlink is equal to the linked path.
    Freebie/DonationWare: check-these.info
    Custom solutions: Hostwick.com

  10. #10
    SitePoint Member
    Join Date
    Sep 2005
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay! Thank you. Now I see what caused the error discussed above, or at least one way around it.

    [root@u15158424 httpdocs]# ls -ltr | grep bug
    -rw-r--r-- 1 root root 5795840 Sep 1 12:38 bugzilla-2.18.3.tar
    lrwxrwxrwx 1 root apache 15 Sep 4 06:52 bugzilla -> bugzilla-2.18.3
    drwxr-xr-x 13 root apache 4096 Sep 13 13:23 bugzilla-2.18.3

    [root@u15158424 bugzilla]# ls -ltr .htaccess
    -rwxr-xr-x 1 root root 239 Sep 13 13:23 .htaccess

    Things changed. This time I got a directory listing instead of seeing the index.cgi being run and displayed. And like the last time I ran into this, opening the index.cgi in the URL or clicking on it just displays the text instead of "running' it.

    Here's my htaccess file:

    # don't allow people to retrieve non-cgi executable files or our private data
    <FilesMatch ^(.*\.pl|.*localconfig.*|runtests.sh)$>
    deny from all
    </FilesMatch>
    <FilesMatch ^(localconfig.js|localconfig.rdf)$>
    allow from all
    </FilesMatch>

    I've tried adding index.cgi in there, but it failed. This may be partly due to commented out sections of httpd.conf.

    What do you recommend as settings in the conf file and the .htaccess file to get index.cgi, etc. to run in the bugzilla directory, outside of the "cgi space"?

    Thanks again.

  11. #11
    SitePoint Evangelist
    Join Date
    Aug 2005
    Posts
    512
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by BugzillaKilla
    Okay! Thank you. Now I see what caused the error discussed above, or at least one way around it.
    I told you in the first reply .....

    [root@u15158424 bugzilla]# ls -ltr .htaccess
    -rwxr-xr-x 1 root root 239 Sep 13 13:23 .htaccess
    644 is enough for .htaccess

    Things changed. This time I got a directory listing instead of seeing the index.cgi being run and displayed. And like the last time I ran into this, opening the index.cgi in the URL or clicking on it just displays the text instead of "running' it.

    I've tried adding index.cgi in there, but it failed. This may be partly due to commented out sections of httpd.conf.

    What do you recommend as settings in the conf file and the .htaccess file to get index.cgi, etc. to run in the bugzilla directory, outside of the "cgi space"?

    Thanks again.
    Are you talking about DirectryIndex ?
    Or something else?

    Usually, .cgi can run from any directory.

    Please show .htaccess of document root, as well.
    Also, please learn to show error log and/or response code for the URL in question.
    Freebie/DonationWare: check-these.info
    Custom solutions: Hostwick.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •