SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    Unauthorized Web Theologian emmzee's Avatar
    Join Date
    Jan 2004
    Location
    Mississauga, Ontario, Canada
    Posts
    738
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Can't see other computers when I assign static IP

    Today I tried to copy a file off another computer on the network, and was surprised that my computer was the only one listed in the @HOME workgroup. So I start thinking, "Oh no, I'm back to the Win95 days of mysteriously disappearing computers in Network Neighborhood!!"

    Well, after some testing, and a lot of Google searching, I have been able to figure out how to "fix" the problem. A couple days ago I setup a static IP address for this machine so that I could forward some ports (I just got this new PC, for the few days after I got it I was using a dynamic IP). Everything worked great. But apparently whenever I set a static IP for this machine, I can no longer see any other computers when I try to browse the network!

    ie:
    Set this PC to have a dynamic IP address: Can see the other 3 computers, access the files, etc.
    Set it back to static IP: Can only see my own computer.


    All the computers are in the same workgroup (@HOME). They're connected through a Linksys BEFSR41 router. This machine is running XP Home SP2, the other 3 machines are all Win98. I *cannot* ping the other computers on the network when I have a static IP assigned to this PC. I *can* access the internet whether I have a static IP or a dynamic IP.

    Any help / suggestions how I could get this working while keeping a static IP address would be great, I have no idea why it doesn't work? :/ Thanks all!

    Here's the output of ipconfig /all on this machine (with static IP; its the Local Area Connection that I am using, not the Wireless which is disabled atm):
    Windows IP Configuration

    Host Name . . . . . . . . . . . . : zemme
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network Connection
    Physical Address. . . . . . . . . : 00-12-F0-0D-A4-86

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Marvell Yukon Gigabit Ethernet 10/100/1000Base-T Adapter, Copper RJ-45
    Physical Address. . . . . . . . . : 00-13-D4-02-B1-89
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.0.102
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 24.153.22.67
    24.153.22.195
    And here's what I get from browstat status:
    Status for domain @HOME on transport \Device\NetBT_Tcpip_{E36F7F1E-31D4-4C8C-B536-3D04D0CBC6B3}
    Browsing is active on domain.
    Master browser name is: ZEMME
    Master browser is running build 2600
    1 backup servers retrieved from master ZEMME
    \\ZEMME
    There are 1 servers in domain @HOME on transport \Device\NetBT_Tcpip_{E36F7F1E-31D4-4C8C-B536-3D04D0CBC6B3}
    There are 1 domains in domain @HOME on transport \Device\NetBT_Tcpip_{E36F7F1E-31D4-4C8C-B536-3D04D0CBC6B3}

  2. #2
    SitePoint Wizard
    Join Date
    Jan 2001
    Location
    Grand Rapids, MI
    Posts
    1,284
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you run the home network configuration thingy once you did that and upload it to the other PC's?

  3. #3
    Unauthorized Web Theologian emmzee's Avatar
    Join Date
    Jan 2004
    Location
    Mississauga, Ontario, Canada
    Posts
    738
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, I tried re-running the Network Setup Wizard but that didn't do anything. I haven't tried messing around with the other PCs, because they seem to be working fine ...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •