SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Apr 2001
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    WYSIWYG Table problem

    I'm having some problems with Frontpage 2000 on making a table inside a table. Please visit: http://progex.50megs.com/table.htm (please disregard the table/banner ad at the top).

    The table format looks fine in IE 5.x+ and Netscape 6.x+. However, it looks disfigured in Netscape 4.5. I'm not sure what's going on. Can someone fix this up so it's compatible with Netscape 4.5? Thanks alot!

    -- I know that Frontpage 2000 isn't the best. So I'm trying to fill my knowledge with Dreamweaver =)
    (`.[www.paraform.com].)
    ParaForm is coming soon!

  2. #2
    SitePoint Wizard Aes's Avatar
    Join Date
    Jun 2001
    Location
    Oklahoma
    Posts
    3,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bah -- too much trash in that code.
    ::stares blankly at FrontPage:: Why why why?
    Try this:
    Code:
    <table border="0" cellpadding="0" cellspacing="0" width="70%" style="margin-top: 0; margin-bottom: 0">
    <tr>
    <td width="1%"><img border="0" src="pix.gif" width="5" height="163" /></td>
    <td width="196%" background="_btm_bg2.gif" align="center">
    <table border="0" cellpadding="0" cellspacing="0" width="38%" height="10">
    <tr>
    <td width="111%" height="1" bgcolor="#FFFFFF" colspan="3"><img border="0" src="_btm_tborder.gif" width="340" height="12" /></td>
    </tr>
    <tr>
    <td width="5%" height="21" bgcolor="#FFFFFF">&nbsp;</td>
    <td width="101%" height="21" bgcolor="#FFFFFF">
    <p align="center">dfgdfgdfgdf</p>
    </td>
    <td width="5%" height="21" bgcolor="#FFFFFF">&nbsp;</td>
    </tr>
    <tr>
    <td width="111%" height="1" colspan="3" bgcolor="#FFFFFF"><img border="0" src="_border_btm.gif" width="340" height="12" /></td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    Try that and tell me if you have the same problem. Basically, FrontPage set the table in the middle to center like three different times using the DIV tag as well as the depreciated CENTER tag. I'm not saying that's the cause, indeed a lot of the trash code is, but it's just one of the joys of using FP. Hope this helps. Happy coding!
    Last edited by Aes; Jul 19, 2001 at 20:43.
    Colin Anderson
    Ambition is a poor excuse for those without
    sense enough to be lazy.

  3. #3
    SitePoint Wizard creole's Avatar
    Join Date
    Oct 2000
    Location
    Nashvegas Baby!
    Posts
    7,845
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    First off, you have to tell us what you are wanting the table to do. What are you triying to accomplish?
    Adobe Certified Coldfusion MX 7 Developer
    Adobe Certified Advanced Coldfusion MX Developer
    My Blog (new) | My Family | My Freelance | My Recipes

  4. #4
    SitePoint Wizard Aes's Avatar
    Join Date
    Jun 2001
    Location
    Oklahoma
    Posts
    3,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    His coding looks good in IE and NS6, but not in NS4.x versions. He's just wanting to make it look good in NS4.x as well.
    Colin Anderson
    Ambition is a poor excuse for those without
    sense enough to be lazy.

  5. #5
    applying the spf lotion V + E + R + T's Avatar
    Join Date
    Apr 2001
    Location
    USA
    Posts
    306
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello,
    Thanks for the code, however, it still didn't display correctly with Netscape 4.5. Anyways, what was happening was that the '_btm_bg2.gif' background image on the bigger table was somehow the default bground of the middle table. So I just created a white .gif image and placed it as the bground of the middle table. So now, it's fixed.

    Sorry if this is confusing, I can't really explain it well. Thanks for the cleaned-up code! WYSIWYG... blah.
    Proud SPF member since 2001!

  6. #6
    SitePoint Wizard Aes's Avatar
    Join Date
    Jun 2001
    Location
    Oklahoma
    Posts
    3,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I see. All right, I understand. I misinterpreted the problem. Netscape seems to confuse background images often displaying the background image of one table as the background image of another table within that first table, thus ruining the entire affect one is trying to create. Reglardless, I'm glad you were able to solve it. =)
    Colin Anderson
    Ambition is a poor excuse for those without
    sense enough to be lazy.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •