SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Nov 2000
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Tables, Netscape and IE...

    Here is the situation. I am creating a website using tables. I have created two images that instead of just having a plain background, have a textured one. Now, I have taken a sliver of this background and I am using it as a background for some of the cells in the table. Now, here is the problem:

    1. If I just use the background gif inside separate cells in the table, people using IE cannot see the textured background. They just see the background of the entire page. So they see the two images and then instead of the images being surrounded with the background texture they are just seeing the color of the page - and it didnt look like that for me when I previewed it.

    2. To fix that what I did was make the entire background of the table that textured image and then as I needed, overwrote other cells with a normal background color. This seemed to fix the problem for people who would be using IE. Yet, when the page is viewed with Netscape, the overridden background colors in the cells are not there. They are seeing the entire table with the textured background.

    Am I missing something here? How can I have the visitors just see the textured background (the two images are centered inside two different cells) surrounding the images and that is it?

    I hope this post makes sense. If anybody wants to see what I am talking about, email me and I'll send a URL to look at it.

    Thanks
    Jay

  2. #2
    The Hiding One lynlimz's Avatar
    Join Date
    Jul 2000
    Location
    Singapore
    Posts
    2,103
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How about a screenshot? *)
    "Imagination is more important than knowledge. Knowledge is limited. Imagination encircles the world."
    -- Albert Einstein

  3. #3
    SitePoint Evangelist pip's Avatar
    Join Date
    Jun 2001
    Location
    Cape Town, South Africa
    Posts
    548
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I suppose this is a typical IE vs. Netscape thing. I will have to see the code and the result before I can say anything.

    Otherwise you're gonna have to go the long way around and implement some browser compatibility scripts.
    - Pip
    ---------------------------------------------------------------------------------
    Nothing takes the taste out of peanut butter quite like unrequited love.

  4. #4
    Marketing Guru ;) Johan Malmberg's Avatar
    Join Date
    Jun 2001
    Location
    Sweden
    Posts
    266
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    the same thing happened to me a while ago. But I canīt remember how I solved the problem.

    I will do some research

  5. #5
    SitePoint Wizard creole's Avatar
    Join Date
    Oct 2000
    Location
    Nashvegas Baby!
    Posts
    7,845
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Tables, Netscape and IE...

    Originally posted by jayc28
    Yet, when the page is viewed with Netscape, the overridden background colors in the cells are not there. They are seeing the entire table with the textured background.
    A screenshot would be the best bet. But, let me take a stab at this. Netscape is capable of seeing a background image, it is also capable of seeing a background color inside a cell. So, since you say that in NS you only see the background image, then it sounds like something is wrong with your HTML.

    PLease post either some code or a link to your page. That will help us diagnose the problem for you.

    cheers
    Adobe Certified Coldfusion MX 7 Developer
    Adobe Certified Advanced Coldfusion MX Developer
    My Blog (new) | My Family | My Freelance | My Recipes


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •