SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist sputza's Avatar
    Join Date
    Jan 2002
    Location
    Canada
    Posts
    528
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Postion issues again

    I need a hand figuring out whats going on here. The UL isnt showing up within the div. Attached is a screen shot from FF.

    HTML Code:
    <!-- Start Header Include-->
         <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
         		"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
         <html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
         <head>
         <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
         <title>Merit Contractors Association - Admin Console</title>
         <link href="css/layout.css" rel="stylesheet" type="text/css" />
         <link rel="shortcut icon" href="images/icon/favicon.ico" />
         </head>
         <body>
         <!--Start Design-->
         <div id="container">
           <div id="adminHeader">
         	<h1>Merit Contractors Association - Admin Console</h1>
           </div>
           <div id="adminNav">Navigation:
           <ul>
           <li>Home</li>
           </ul>
           </div>
           <div id="adminContent">This is where the admin options will be</div>
         </div>
     <div id="adminCopyright"><p></p>Copyright &copy; Merit Contractors Association. All Rights Reserved. Created by <a href="http://www.lowgravity.ca" target="_blank">Steven Watkins</a>.</p> <p>Version 1.0.0. Website Meets Current Web Standards: <a href="http://validator.w3.org/check?uri=referer">XHTML 1.0</a> and <a href="http://jigsaw.w3.org/css-validator/">CSS 2.0</a>.</p>
         </div>
         <!--End Design-->
         </body>
         </html>
         <!-- End Footer Include-->
    CSS:

    Code:
        body {
        	font-family: Arial, Helvetica, sans-serif;
        	text-align: center; /* IE Fix */
        	margin: 0px;
        }
        
        a {
        	color: #890000;
        	text-decoration: underline;
        }
        
        h1 {
        	font-family: Arial, Helvetica, sans-serif;
        	font-size: 16px;
        	font-weight: bold;
        	color: #333333;
        	margin: 0px;
        	padding: 2px;
        }
        
        /* DESIGN LAYOUT */
        
        #container {
        	width: 740px;
        	height: auto;
        	margin: 0px auto 0px auto;
        	text-align: left; /* Part of the IE Fix */
        	border: 1px;
        	border-color: #cccccc;
        	border-style: solid;
        	background-color: #eaeaea;
        }
        
        #adminHeader {
        	width: 100%;
        	height: 20px;
        	border-bottom: 1px solid #cccccc;
        }
        
        #adminNav {
        	width: 200px;
        	height: auto;
        	float: left;
        	border-right: 1px solid #cccccc;
        }
        
        adminContent {
        	width: 540px;
        	height: auto;
        	float: right;
        }
        
        #adminCopyright {
        	font-size: 10px;
        	color: #333333;
        	clear: both;
        }
        
        #adminCopyright p {
        	margin: 0px;
        	padding: 0px;
        }
        #adminCopyright a {
        	color: #890000;
        	text-decoration: underline;
        }
        #adminCopyright a:hover {
        	color: #333333;
        }
    Any help would be great! Thanks in advance.
    Attached Images Attached Images
    Steven Watkins
    Chief Web Ninja
    Code Monkey Interactive
    lowgravity.ca

  2. #2
    SitePoint Wizard mPeror's Avatar
    Join Date
    Mar 2005
    Location
    Saudi Arabia
    Posts
    1,724
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Not 100% sure what's going on , but if you change the container's height to say 90px instead of 'auto' it would fix it. Adding more list items won't automatically insrease the DIV height in FireFox though.

    This question should be in the CSS board by the way

  3. #3
    SitePoint Evangelist sputza's Avatar
    Join Date
    Jan 2002
    Location
    Canada
    Posts
    528
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by mPeror
    This question should be in the CSS board by the way
    Oops... i hate being one of those people who do that....

    Oh well.

    Thanks for the help!
    Steven Watkins
    Chief Web Ninja
    Code Monkey Interactive
    lowgravity.ca


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •