SitePoint Sponsor

User Tag List

Results 1 to 12 of 12

Thread: Weird error

  1. #1
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Weird error

    im getting this error;

    Code:
    Microsoft JET Database Engine error '80040e14' 
    
    Syntax error in FROM clause. 
    
    /ob/new/newsapp.asp, line 48
    for the following line of asp

    Code:
    objDBCon.Execute("UPDATE tblsSetup SET [font] = '" & checkMess(request.form("fontFace")) & "', [fontColor] = '" & checkMess(request.form("fontColor")) & "', [fontSize] = '" & fontSize & "', [borderWidth] = " & checkMess(request.form("borderWidth")) & ", [borderColor] = '" & checkMess(request.form("borderColor")) & "', [titleColor] = '" & checkMess(request.form("titleColor")) & "', [titleFont] = '" & checkMess(request.form("titleFont")) & "', [titleSize] = '" & titleSize & "', [bold] = " & setBold & ", [italic] = " & setItalic & ", [defineLinks] = " & defineLinks & ", [linkColor] = '" & checkMess(request.form("linkColor")) & "', [linkDeco] = '" & linkDeco & "',[linkHover] = '" & checkMess(request.form("linkHover")) & "', [linkHoverDeco] = '" & linkHoverDeco & "', [linkVisited] = '" & checkMess(request.form("linkVisited")) & "', [linkVisitedDeco] = '" & linkVisitedDeco & "' WHERE ID = 1")
    ne1 got ne idea whats wrong?

  2. #2
    SitePoint Wizard silver trophy Jeremy W.'s Avatar
    Join Date
    Jun 2001
    Location
    Toronto, Canada
    Posts
    9,123
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Well, I'd say it's cause you suck, but I know differently

    btw, if anyone's looknig for the submit button, it's in teh middle of the screen

    Welcome chris, what's shaking?!
    SVP Marketing, SoCast SRM
    Personal blog: Strategerize
    Twitter: @jeremywright

  3. #3
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    sunny, i wouldnt laugh, its from the news board that ur using on studiococo :P

    dont have a clue whas doing it works fine in other directorys... this computer is FUBAR

  4. #4
    SitePoint Wizard westmich's Avatar
    Join Date
    Mar 2000
    Location
    Muskegon, MI
    Posts
    2,328
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are those brackets part of your SQL statement or are you trying to highlight the code in some way?

    You might want to try breaking that into several lines to narrow your error message.
    Westmich
    Smart Web Solutions for Smart Clients
    http://www.mindscapecreative.com

  5. #5
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ive got the brackets there as part of the SQL cos according to the m$ site, the error is a result of me using a reserve word, and that was the way to fix it.

    But this is struck mas as weird cos the error jus appeared and it was working fine b4 (look at studiococo's site, its the newsboard on the right)

  6. #6
    SitePoint Wizard silver trophy Jeremy W.'s Avatar
    Join Date
    Jun 2001
    Location
    Toronto, Canada
    Posts
    9,123
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Well, if the above code is from the file you just sent me, it works.

    I just emailed it to kode and everything is fine and dandy with it (after I fixed your whacked formatting ).
    SVP Marketing, SoCast SRM
    Personal blog: Strategerize
    Twitter: @jeremywright

  7. #7
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hey! i like my formatting...

  8. #8
    SitePoint Wizard silver trophy Jeremy W.'s Avatar
    Join Date
    Jun 2001
    Location
    Toronto, Canada
    Posts
    9,123
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    spell after me:

    r-e-a-d-a-b-l-e
    SVP Marketing, SoCast SRM
    Personal blog: Strategerize
    Twitter: @jeremywright

  9. #9
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i can read t jus fine... well... not when im hungover, but then again, i cant rdo much then

  10. #10
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    but wait a minute! slagging my formatting is not helping fix my problem!! :P

  11. #11
    SitePoint Wizard silver trophy Jeremy W.'s Avatar
    Join Date
    Jun 2001
    Location
    Toronto, Canada
    Posts
    9,123
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I took a look and can't find a reason for the error, there isn't even a bloody FROM clause. I even did a search to make sure you didn't mistype "form" or something...
    SVP Marketing, SoCast SRM
    Personal blog: Strategerize
    Twitter: @jeremywright

  12. #12
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it might be a PWS problem... it works in a different folder...

    wish my work would hurry up and get me win2k


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •