SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Enthusiast wdfadude's Avatar
    Join Date
    Jun 2004
    Location
    U.S.A.
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Enterprise Manager/SQL connection problems

    I'm having a bizarre problem that has only crept up today.

    Although I've been connecting to the same server for months without incident, starting this morning I cannot connect to a MS SQL Server via Enterprise Manager. It just happened "out of the blue"; no settings were changed or tampered with. I did install Adobe Creative Suite CS2 yesterday afternoon, but I was able to connect to the same SQL server successfully for about a half hour before the problems started. No other software has been installed other than that.

    Whenever I attempt to connect, Enterprise Manager freezes up for about 30-45 seconds and then responds with this message:

    A connection could not be established to XXXX
    Reason: SQLServer does not exist or access denied
    ConnectionOpen (Connect())..
    Please verify SQL Server is running and check your SQL Server registration properties (by right-clicking on the
    XXXX node) and try again.

    I know SQL Server is running, because the web apps that uses it works fine.

    I've tried to connect via Enterprise Manager from other PCs at my work, and they are able to connect fine with the same exact settings.

    I've since uninstalled and re-installed Enterprise Manager twice, deleted and re-inserted the server settings, all to no avail.

    Has anybody heard of any similar incidents? Could it be an IP blockage of some sort?

  2. #2
    SitePoint Wizard HarryR's Avatar
    Join Date
    Dec 2004
    Location
    London, UK
    Posts
    1,376
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    I know this probably isn't going to help, but you can try it anyway: Restart the Microsoft SQL server (actually reboot the machine).

    I've had a couple of weird issues where a web application would just stop working, everything else worked fine and I could even connect to it using Enterprise Manager with the same connection settings as the web app on the other machine.

    I've seen some very strange things, and this is in the top 10.

  3. #3
    SitePoint Enthusiast wdfadude's Avatar
    Join Date
    Jun 2004
    Location
    U.S.A.
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I talked to my host, and after a reboot, it is still not working.

    My host informed me that the SQL Server operates on port 1501 instead of the default 1433. I understand that, but how do I check or change my port settings to make sure nothing has been reset on my end? I'm using a Windows 2000 machine to connect.

  4. #4
    S1tepoint Surfer drochili's Avatar
    Join Date
    Aug 2002
    Location
    Mississauga, Canada
    Posts
    466
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Interesting... can you try creating a new username from a machine that can connect to it, and then use that new username from your machine?
    My Blog: DR's Corner
    Random babble: TheCoolerZone

  5. #5
    SitePoint Guru puco's Avatar
    Join Date
    Feb 2005
    Location
    Slovakia
    Posts
    785
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    In your connection string add , <port#> after the server name:

    Instead of dbserver\instance write dbserver\instance,1501
    Martin Pernecky

  6. #6
    SitePoint Enthusiast wdfadude's Avatar
    Join Date
    Jun 2004
    Location
    U.S.A.
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by drochili
    Interesting... can you try creating a new username from a machine that can connect to it, and then use that new username from your machine?
    Nope, doesn't work.

  7. #7
    SitePoint Enthusiast wdfadude's Avatar
    Join Date
    Jun 2004
    Location
    U.S.A.
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by puco
    In your connection string add , <port#> after the server name:

    Instead of dbserver\instance write dbserver\instance,1501
    It has nothing to do with the connection string or code; it all runs perfectly fine. It's Enterprise Manager on my machine that's not able to connect.

  8. #8
    S1tepoint Surfer drochili's Avatar
    Join Date
    Aug 2002
    Location
    Mississauga, Canada
    Posts
    466
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Dunno what else could be the problem then.. maybe your machine IP got blocked from your host's site somehow?

    you're using DHCP at office? Can you release and renew IP and see it that does anything?
    My Blog: DR's Corner
    Random babble: TheCoolerZone

  9. #9
    SitePoint Guru puco's Avatar
    Join Date
    Feb 2005
    Location
    Slovakia
    Posts
    785
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you checked the connectivity to the database server? Try pinging it and telneting to the port. If you get connection refused then the hosting company can be blocking the port. And did they change the SQL port recently? And I meant you should write the port in the Enterprise Manager. Try adding a new server registration with port explicitly specified.
    Martin Pernecky

  10. #10
    SitePoint Enthusiast wdfadude's Avatar
    Join Date
    Jun 2004
    Location
    U.S.A.
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, the problem's solved but I don't know exactly what happened. After several days, the host had set up a test account with a new username and password and I was able to connect with no problem. Shortly afterwards, just on a whim, I decided to try the previous account that wasn't working...and it worked. Although the tech at the hosting company denies it, it's a possibility that he or they fixed something on their end. Whatever it was, it was very odd.

    Thanks for your replies and suggestions, folks.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •