SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Member
    Join Date
    Nov 2003
    Location
    California
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Unable to view coding using view source

    I have a friend who wants me to add meta tags to her web page and normally I can click on View Source and see the coding in a web page. When I try to view the coding of her pages at http://www.houstonrobertson.com I don't get the view source menu.

    Her page uses a splash page. Could this be the reason? Is there some way I can get in there just to see if she has meta tags? She's not sure if her designer used them.

  2. #2
    SitePoint Enthusiast Imprint's Avatar
    Join Date
    May 2005
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    She does not have meta tags on her website, apart from:

    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    Btw, the 'View Source'-function does work for me without a problem. A splash page cannot be the cause of not being able to see the source of a website. A splash page is just another HTML page which links to the main website. It only functions as a sort of entry-post, apart from that it does not do much more and certainly does not preclude you from viewing the source as far as I know.
    "Two roads diverged in a wood, and I
    I took the road less travelled by,
    And that has made all the difference."
    Discover the master...

  3. #3
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,158
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you are using Internet Explorer (Windows), try clearing your Temporary Internet Files folder. If that becomes full, the View Source stops working (go figure).

    OTOH, the source of that page should only be used as a warning example!
    (No doctype, invalid markup, inaccessible, only images and no alt text, ...)
    Birnam wood is come to Dunsinane

  4. #4
    SitePoint Member
    Join Date
    Nov 2003
    Location
    California
    Posts
    16
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks. That was a big help. I was actually able to get in on the menu by going to source in IE. I still can't figure out why it's not showing when I right click the mouse.

  5. #5
    SitePoint Evangelist
    Join Date
    Feb 2005
    Posts
    581
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by AutisticCuckoo
    If you are using Internet Explorer (Windows), try clearing your Temporary Internet Files folder. If that becomes full, the View Source stops working (go figure).

    OTOH, the source of that page should only be used as a warning example!
    (No doctype, invalid markup, inaccessible, only images and no alt text, ...)
    Yeah; that's quite possibly one of the worst pages I have ever seen. With images disabled, all I see is several blocks of colour. That designer should be fired, dragged out into the middle of the street, and shot.
    I will not flame the newbies,
    I will not flame the newbies,
    I will flame the newbies...
    Table free is the way to be!

  6. #6
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,158
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    LOL
    Or at least educated about web standards and accessibility.
    Birnam wood is come to Dunsinane

  7. #7
    bronze trophy
    Join Date
    Dec 2004
    Location
    Sweden
    Posts
    2,670
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The META element could be lying about the real charset in use.

    For instance, what charset is this document in? (It's sent over HTTP)
    Code:
    Content-Type: text/xml
    
    <?xml version="1.0" encoding="utf-8"?>
    <html xmlns="http://www.w3.org/1999/xhtml">
     <head>
      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
      <title>Guess the charset!</title>
     </head>
     <body><p>Is it utf-8, iso-8859-1, or perhaps something else?</p></body>
    </html>
    Edit:

    Tommy: correct.
    Last edited by zcorpan; Jul 8, 2005 at 11:48.
    Simon Pieters

  8. #8
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,158
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Birnam wood is come to Dunsinane


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •