SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2004
    Location
    Cincinnati, OH
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    What's it asking me for?

    I just began working with a new website template in FrontPage. When I go to the Preview mode I get an error message that it is expecting to see a file called pvw36.htm.

    When I go to that specific line in the code I see this:

    <img src="file:///C:/My%20Documents/My%20Webs/Visitors2Customers.com/807/images/header.jpg" usemap="#Map" border="0" width="700" height="100">
    </div>

    I sense that the problem is that it's not finding the header.jpg. Yet it is in my images directory. It's probably pretty simple but it's got me stumped. Any ideas?


    Thanks for your help.

  2. #2
    SitePoint Guru gavwvin's Avatar
    Join Date
    Nov 2004
    Location
    Cornwall, UK
    Posts
    686
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you shouldn't have file:///C:/My%20Documents/My%20Webs/Visitors2Customers.com/807/images/header.jpg in your src because that relates to a specific address as it exists on your computer. If you ever want to upload it, your hosts computer will be set up differently (your site won't be in C:/My%20Documents/My%20Webs/Visitors2Customers.com) so it won't find it.
    Your links should be relative to the html file: eg if your html file is in C:/My%20Documents/My%20Webs/Visitors2Customers.com then you should have <img src="807/images/header.jpg" />. I don't use frontpage but theres probably an option you can tick when you select the file "use a relative link" or something.

  3. #3
    SitePoint Evangelist sputza's Avatar
    Join Date
    Jan 2002
    Location
    Canada
    Posts
    528
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My first suggestion is to not use Frontpage... its full of bugs and in the end creates more problems with your website than its worth. If you would like to use a WYSIWYG Editor, use Dreamweaver MX 2004. All WYSIWYG editors have issues, but Dreamweaver is better than any other I know of. This is just my $0.02

    Your problem is a issue with paths. Your paths are absolute and they need to be relative. As gavwvin said, change your paths to relative paths.

    Tip: Frontpage likes to mess with peoples code. I would find the option that allows you to chose relative links rather than absolute. My reason for this is, if you change the link in the code view... the design view may change them back.
    Steven Watkins
    Chief Web Ninja
    Code Monkey Interactive
    lowgravity.ca


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •