SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Rollover graphic button problem. Any help?

    Hi,
    I have been unable to figure out the following problem. Any advice would be appreciated!

    I have 2 rows of graphic buttons on a page. The buttons are blue, and turn red on hover. The problem is, when you visit the site for the first time, the buttons don't return to blue on mouse-out. But, once you have visited the page the button links to (once the page is cached) the button does become blue on mouse-out. How can I fix the code so the buttons always turn blue on mouse-out, even when the site isn't yet cached?

    You can see a sample here: halve.ca/french/
    TIA!

  2. #2
    SitePoint Guru hgilbert's Avatar
    Join Date
    Dec 2004
    Location
    London
    Posts
    839
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it works here


  3. #3
    SitePoint Guru hgilbert's Avatar
    Join Date
    Dec 2004
    Location
    London
    Posts
    839
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ah ok you mean in Internet Explorer ....!

    you are using javascript
    try the javascript forum
    thought it was a CSS rollover
    which would be better and works even with js switched off


  4. #4
    SitePoint Guru hgilbert's Avatar
    Join Date
    Dec 2004
    Location
    London
    Posts
    839
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    use CSS only its much better

    a {background-image: url('blue.jpg')
    a.hover, a.focus {background-image: url('red.jpg');



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •