SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast UCAP's Avatar
    Join Date
    Jun 2001
    Location
    Switzerland
    Posts
    57
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    No $HTTP_REFERER in NS

    If I'm calling my php-script by an IMG-tag (e.g. <IMG src='http://www.somethi.ng/myscript.php'> )
    everything works fine and $HTTP_REFERER is around. Like this I can get the calling page's URL (where the img-tag was placed)

    Now, I want to call this php-script by JavaScript (e.g. <script language='JavaScript' src='http://www.somethi.ng/myscript.php'></script> )
    In IE this works perfectly and $HTTP_REFERER gets the correct value. In NS (4.77 or NS6, same thing) $HTTP_REFERER is undefined and I have no idea how to get the calling page's URL!

    I'd appreciate your help. I've been working on this for quite a long time and I need to get a solution.

    Thanks

  2. #2
    SitePoint Enthusiast UCAP's Avatar
    Join Date
    Jun 2001
    Location
    Switzerland
    Posts
    57
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Does nobody have an answer??
    There must be somebody who can at least guide me in the right direction...
    Last edited by UCAP; Jul 4, 2001 at 10:11.

  3. #3
    SitePoint Enthusiast UCAP's Avatar
    Join Date
    Jun 2001
    Location
    Switzerland
    Posts
    57
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    *bump*

    I'm still desperately looking for an answer...

  4. #4
    SitePoint Zealot
    Join Date
    May 2001
    Location
    UK
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Tried using ENV variables ?

    I seem to get HTTP REFERER undefined even in IE sometimes.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •