SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Jun 2005
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with simplexml functions

    I've been using php for a little while and now want to start parsing xml documents with a view to storing user info etc. This is a newbie question, however I have searched the forum and still have the problem. When I attempt to execute a simplexml_load_file or simplexml_load_string function I get an error telling me I'm using an unknown function. I know that these functions work only with php5 and so have only two q's.

    1. I'm sure that I have php5 installed as I installed it recently but how can I check?

    2. I also know that I have to ensure that the simplexml extension in the php package is enabled. Could you tell me what file to look in what to set?

    Thanks very much

    Jim

  2. #2
    SitePoint Zealot sidhighwind's Avatar
    Join Date
    Aug 2003
    Location
    Indianapolis, IN
    Posts
    163
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    to check what's been compiled into php use this in a blank page.

    PHP Code:
     <? phpinfo(); ?>
    It will tell you what version you are running and if xml is compiled in. Look for a section called XML or Simple XML.

    From the way it sounds is that you don't have xml compiled in.

    Jon
    Jon Whitcraft :: It's the Bombdiggity!
    Web Applications Developer :: Zend Certified Engineer
    http://www.indycar.com

  3. #3
    SitePoint Member
    Join Date
    Jun 2005
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks a lot


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •