I might have missed a naming discussion a while back but do you think the InputController should be renamed "Request"? The current name kind of threw me initially until I realised what it was.

I'd make validateRequest and filterRequest "private" (the php4 way prefixed with an underscore...) if that isn't already your intention.

Also - these things are a matter of personal preference - I'd rename processRequest to isValid. Then you have:

PHP Code:
   // set everything up..
   
   
if($request->isValid()) {
       
// continue with the script
   
} else {
       
// bad syntax 400 page