SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    Serial Publisher silver trophy aspen's Avatar
    Join Date
    Aug 1999
    Location
    East Lansing, MI USA
    Posts
    12,937
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Netscape table cells with relative widths and tiled backgrounds

    I usually do not use relative width tables because I prefer to strictly define everything. However we have a client who wants 100% width on his website. So I need to use relatively widths.

    The problem is Netscape wont render the background in these cells.

    Like for the top of the page. I have a 1x110 pixel graphic I want tiled 100% of the document width. I know Netscape wont render an empty table cell but even with something in the cell it wont render it.

    Code:
    <table width = "100%" height = "100%" cellpadding = "0" cellspacing = "0" border = "0">
    <tr>
    <td colspan = "2" background = "images/right_scroll2.gif" height = "109" align = "left" valign = "top" width = "100%"><img src = "images/top3.gif" height = "109"></td>
    </tr>
    Could it perhaps be my use of colspan in conjunction with the 100% table width that netscape is balking at?

    However this problem also occurs with the bottom left cell.

    Code:
    	<tr>
    	<td width = "175" height = "100%" background = "images/bottom_scroll.gif">&nbsp;<img src = "images/transparent.gif" width = "1" height = "1"><br><br></td>
    	</tr>
    As you can see I've put tags, a space, and an image in this cell to try to get netscape to render it, and it wont. Although the space does show up, the background does not.

    Any have any ideas on how to get netscape to display these cells correctly?
    Chris Beasley - I publish content and ecommerce sites.
    Featured Article: Free Comprehensive SEO Guide
    My Guide to Building a Successful Website
    My Blog|My Webmaster Forums

  2. #2
    SitePoint Wizard creole's Avatar
    Join Date
    Oct 2000
    Location
    Nashvegas Baby!
    Posts
    7,845
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Chris, do you have a link. It would be easier for us to visualize.
    Adobe Certified Coldfusion MX 7 Developer
    Adobe Certified Advanced Coldfusion MX Developer
    My Blog (new) | My Family | My Freelance | My Recipes

  3. #3
    Serial Publisher silver trophy aspen's Avatar
    Join Date
    Aug 1999
    Location
    East Lansing, MI USA
    Posts
    12,937
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    http://209.123.141.99/top.php

    And I just changed the code a little bit.

    Table layout is like this

    [code]
    topleft|topmid|topright
    menu | content area
    [code]

    The menu cell contains 2 nested tables, the content area cell has a colspan of 2.

    Its the bottom cell of the last nested menu table that is not working, and its the topright cell that is not working.

    In Netscape.. ie it works great.
    Chris Beasley - I publish content and ecommerce sites.
    Featured Article: Free Comprehensive SEO Guide
    My Guide to Building a Successful Website
    My Blog|My Webmaster Forums

  4. #4
    SitePoint Wizard creole's Avatar
    Join Date
    Oct 2000
    Location
    Nashvegas Baby!
    Posts
    7,845
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can give you a few suggestions. It would probably be more effiecient if you were to make that yellow area with the shadow as a tiling body background image. That way it will always be there down the left side. [image]

    On the top section, you can just set the background for the table and let it tile as it wants to [image]

    Give those a try...
    Adobe Certified Coldfusion MX 7 Developer
    Adobe Certified Advanced Coldfusion MX Developer
    My Blog (new) | My Family | My Freelance | My Recipes

  5. #5
    Serial Publisher silver trophy aspen's Avatar
    Join Date
    Aug 1999
    Location
    East Lansing, MI USA
    Posts
    12,937
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thats how it is set up, netscape wont tile it.
    Chris Beasley - I publish content and ecommerce sites.
    Featured Article: Free Comprehensive SEO Guide
    My Guide to Building a Successful Website
    My Blog|My Webmaster Forums

  6. #6
    Serial Publisher silver trophy aspen's Avatar
    Join Date
    Aug 1999
    Location
    East Lansing, MI USA
    Posts
    12,937
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay, here is a simple webpage that illustrates the problem:

    <html>
    <head>
    </head>
    <body>
    <table border = "0" cellpadding = "0" cellspacing = "0" width = "100%" height = "109">
    <tr>
    <td background = "http://209.123.141.99/images/right_scroll2.gif" height = "109" width = "100%">&nbsp;</td>
    </tr>
    </table>
    </body>
    </html>
    Netscape will not render the background in that table cell. Why?

    Image:http://209.123.141.99/images/right_scroll2.gif
    URL:http://209.123.141.99/test.htm
    Chris Beasley - I publish content and ecommerce sites.
    Featured Article: Free Comprehensive SEO Guide
    My Guide to Building a Successful Website
    My Blog|My Webmaster Forums

  7. #7
    SitePoint Wizard creole's Avatar
    Join Date
    Oct 2000
    Location
    Nashvegas Baby!
    Posts
    7,845
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    dude...that is bizarre...

    I tried putting the image as a background in the TABLE tag, the TR tag and the TD and nothing. I tried everything I could think of and nothing. I KNOW that it supports the background attribute, but maybe it only takes JPGs? I am using the background image attribute for this site and it works fine in Netscape.

    http://ferventrecords.com/newsite/about_us.php3

    Never mind the weird tiling issue. I still have to fix that by putting the image into the TABLE instead of the TD. But that image is a JPG though.
    Adobe Certified Coldfusion MX 7 Developer
    Adobe Certified Advanced Coldfusion MX Developer
    My Blog (new) | My Family | My Freelance | My Recipes

  8. #8
    Serial Publisher silver trophy aspen's Avatar
    Join Date
    Aug 1999
    Location
    East Lansing, MI USA
    Posts
    12,937
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    switching it to a jpeg worked, who'da thunk it.

    Add one more stupid bug to netscape.

    Netscape will not tile or display table backgrounds that are gifs when the table dimensions are relative.
    by the way Creole thats a nice header graphic on that site.
    Last edited by aspen; Jun 27, 2001 at 12:23.
    Chris Beasley - I publish content and ecommerce sites.
    Featured Article: Free Comprehensive SEO Guide
    My Guide to Building a Successful Website
    My Blog|My Webmaster Forums


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •