SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Zealot
    Join Date
    Mar 2001
    Location
    Los Angeles
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    phpBB install question

    I am having a problem with a phpBB install.
    Specs:
    hosted server
    php3
    MySQL with one user one db access, but the user has admin rights in that db.

    Problem:
    Install seemed to go well, but I couldn't login to the admin section after running the install script.

    Already ruled out:
    permissions
    connection string

    I know it's pretty obscure so thanks in advance
    bsacks
    http://www.middlepeak.com

  2. #2
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Los Angeles, California
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you are saying that you cant log into the admin section of phpbb right? If thats the case, does the browser that u tried logging into from have cookies enabled?
    www.iyeinteractive.com - Website Design and Programming
    www.totalnonsense.net - my site, Under Construction

  3. #3
    SitePoint Zealot
    Join Date
    Mar 2001
    Location
    Los Angeles
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes,
    I should have put that in my already ruled out section.
    I also tried it with other browsers. But, I was on Win 2000. I don't know if that makes a difference.
    bsacks
    http://www.middlepeak.com

  4. #4
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Los Angeles, California
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    so ur on the admin login page of phpbb and you type in ur username and password (ur sure they match the username and password u made when you were installing phpbb?) and what happens when u click Log In?
    www.iyeinteractive.com - Website Design and Programming
    www.totalnonsense.net - my site, Under Construction

  5. #5
    SitePoint Zealot
    Join Date
    Mar 2001
    Location
    Los Angeles
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The uname and password are good as far as I can tell. The password is encrypted in the database, but I reinstalled a few times to be sure.

    What happens is that I get the login screen again. I get the error message about needing to have cookies turned on. And thats it.
    But, I checked the cookie folder and the cookie is there.
    Thanks for the help.
    bsacks
    http://www.middlepeak.com

  6. #6
    Ex-SitePointer silver trophy
    Patrick's Avatar
    Join Date
    Oct 2000
    Location
    Harbinger, NC, U.S.A.
    Posts
    4,126
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    You might want to change your cookiedomain in config.php and make it blank or change it from and to www.yourdomain.com or yourdomain.com and see what happens.

  7. #7
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Los Angeles, California
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmm, well to tell u the truth i dont know what else to do, try what iFroggy suggested. If that doesnt work try going to the phpbb forums, i know this is a common problem so they should be able to help
    www.iyeinteractive.com - Website Design and Programming
    www.totalnonsense.net - my site, Under Construction

  8. #8
    Ex-SitePointer silver trophy
    Patrick's Avatar
    Join Date
    Oct 2000
    Location
    Harbinger, NC, U.S.A.
    Posts
    4,126
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Also, what I mean by "make it blank" is this:

    $cookiedomain = ""

    Also, you may be better off asking for help at http://www.phpbbhacks.com/forum (my site). My team is made up of the best phpBB hackers around.

  9. #9
    SitePoint Zealot
    Join Date
    Mar 2001
    Location
    Los Angeles
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for all the help. Sorry I didn't get back to this thread sooner.

    I tried everything that was suggested and had no luck. The message boards on phpBB had a few threads with the same question, but no answers. So I am going to try another bb system.

    Thanks again.
    bsacks
    http://www.middlepeak.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •