SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Guru Lars-Christian's Avatar
    Join Date
    Dec 2004
    Location
    Tromsų, Norway
    Posts
    713
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Shading Effect Troubles

    I am trying to achieve a shading effect on the intro text of this page, but as you can see I have stumbled upon some problems.

    The .shade class works fine, but in order for the .noshade class to be aligned "on top" of the shading, I have to set the position to "absolute", which results in that it doesn't wrap, at all.

    Does anyone have any suggestions on how I can get around this? Setting .noshade to relative instead of absolute doesn't work at all, because that simply results in coming after the .shade text, instead of on top of it.

    Thanks in advance!

  2. #2
    SitePoint Guru DocType's Avatar
    Join Date
    Feb 2005
    Posts
    827
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Is this browser specific?

    I viewed it in Opera and it seems to be working fine.

  3. #3
    SitePoint Guru Lars-Christian's Avatar
    Join Date
    Dec 2004
    Location
    Tromsų, Norway
    Posts
    713
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    *Opens up Opera and IE*

    Hmm.. Yes, it only doesn't wrap in FireFox it seems. In Opera it looks fine, and in IE the white text actually wraps a word later on the last line on my resolution because of the pixel it is to the left compared to the blue text!

    Any suggestions on how to fix the FF problem ?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •