I couldn't help but notice you are running 3.0.3 here; you really should upgrade to 3.0.7 - there were 4 security updates that are pretty well known now. People running 3.0.3 or less have been being targeted by people with scripts.

Just a thought.