SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Enthusiast Wynex's Avatar
    Join Date
    Jul 2004
    Location
    Austria, EU
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation virtual dedicated server: How to update Apache/PHP/MySQL?

    Hi,

    I have been trying to update the apache on my virtual dedicated server hosted by godaddy.
    I already downloaded apache and php and compiled/installed them.
    Apache is in /usr/local/apache2

    I already had apache running (apachectl start) but there was a problem when I tried to load a website because apache didn't know what folder should be displayed for each domain.

    I stopped it and then started the old version of apache using service httpd start.
    Now when I use "apachectl sart" the old version of php starts.

    The Server used PLESK 7.5 and is Linux Redhat 9.0

    Please help me
    Regards, Wynex
    BMX-Zone.com BMX-Forum.com
    ZuneStore.cc

  2. #2
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,656
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    Wynex:

    Similar problem lately. The answer for your location is found in httpd.conf under <Virtual Hosts> where you define DocumentRoot AND in your hosts file which provides the DNS for locally hosted domains. The reason I mentioned the other post is that pippo came in there and identified where the hosts file is located on a Linux box - otherwise, just use whereis to find the file(s).

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator

  3. #3
    SitePoint Enthusiast Wynex's Avatar
    Join Date
    Jul 2004
    Location
    Austria, EU
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    but how can I start the new apache version?
    When I type /usr/local/apache2/bin/apachectl start the old version starts.
    Regards, Wynex
    BMX-Zone.com BMX-Forum.com
    ZuneStore.cc

  4. #4
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,656
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    Wynex,

    Okay, it's obviously a configuration file but I have no idea which one. Best to wait for pippo to answer this one as he's the Linux & Apache EXPERT.

    Sorry :'(

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator

  5. #5
    SitePoint Enthusiast Wynex's Avatar
    Join Date
    Jul 2004
    Location
    Austria, EU
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you.
    Regards, Wynex
    BMX-Zone.com BMX-Forum.com
    ZuneStore.cc

  6. #6
    SitePoint Enthusiast Wynex's Avatar
    Join Date
    Jul 2004
    Location
    Austria, EU
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    got apache running now!

    but there is a new problem:
    Forbidden

    You don't have permission to access / on this server.
    my virtual hosts are:

    PHP Code:
    NameVirtualHost *:80

    <Directory "/home/httpd/vhosts">
            
    AllowOverride All
            Options SymLinksIfOwnerMatch
            Order allow
    ,deny
            Allow from all
    </Directory>

    <
    VirtualHost *:80 >
            
    DocumentRoot /home/httpd/vhosts/mydomain.com/httpdocs
            ServerName lists
            ServerAlias lists
    .*
            
    UseCanonicalName Off
            ScriptAlias 
    /mailman/ /var/mailman/cgi-bin/
            
    Alias /icons/ /var/www/icons/
            
    Alias /pipermail/ /var/mailman/archives/public/
            <
    Directory /var/mailman/archives/>
                    
    Options FollowSymLinks
            
    </Directory>
    </
    VirtualHost
    If I now enter the IP in my browser it should load "/home/httpd/vhosts/mydomain.com/httpdocs" .. but it returns the error-message
    Forbidden

    You don't have permission to access / on this server.
    please help me
    Regards, Wynex
    BMX-Zone.com BMX-Forum.com
    ZuneStore.cc

  7. #7
    SitePoint Enthusiast Wynex's Avatar
    Join Date
    Jul 2004
    Location
    Austria, EU
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    apache's error log:

    Permission denied: /home/httpd/vhosts/mydomain.com/httpdocs/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    What's does it mean?
    Regards, Wynex
    BMX-Zone.com BMX-Forum.com
    ZuneStore.cc

  8. #8
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,656
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    Wynex,

    What I have in my Virtual Hosts section (XP) is:

    Code:
    NameVirtualHost *:80
    
    <VirtualHost *:80>
    ServerName localhost
    DocumentRoot C:/web/apache/Apache2/htdocs/
    </VirtualHost>
    
    <VirtualHost *:80>
    ServerName datakoncepts
    DocumentRoot C:/web/apache/Apache2/htdocs/websites/datakoncepts.com/httpdocs
    ServerPath C:/web/apache/Apache2/htdocs/websites/datakoncepts.com/httpdocs
    </VirtualHost>
    In other words, I think you've got too much in your Virtual Hosts section and that's what MAY be causing the problem.

    Give removing the extraneous directives a go and see if that does it for you.

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •