SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast drorit30's Avatar
    Join Date
    May 2003
    Location
    tel aviv
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem in link when sending HTML email using CDONTS.Newmail

    I have a site where if a user registers he I need to send him a link to validate his registration. I am using CDONTS.Newmail and sending an HTML email as shown below:

    strPassword = "123456789"

    Set objMailer = CreateObject("CDONTS.Newmail")

    objMailer.BodyFormat = 0 'FOR HTML
    objMailer.MailFormat = 0

    htmlLink = "www.mysite.com/validation.asp?email=" & Request.Form("email") & "&code=" & strPassword


    The problem is that some users (about 10%) who register complain that they
    cannot go to this link. When I test it on a numerous email clients I am using (yahoo, gmail, outlook express) they all work, so i assume it is some other email client.
    I had one user send me the email which he received, and it seems that the link to the validation page in the email which he received was split.

    email example:
    To validate you link press on the following link
    www.mysite.com/validation.asp?email=
    user@user.com&code=123456789

    But only the first line was in the href part. The second part was just regular text.

    I know this because when I opened up the html page of the email I saw
    that the </a> was after 'www.mysite.com/validation.asp?email=' and not
    after the end of the whole link.


    I hope I am making myself clear.

    If anyone knows what the problem may me, I would really appreciate your help.

    Thanks in advance.

  2. #2
    Original Gangster silver trophy Thing's Avatar
    Join Date
    Oct 2000
    Location
    Philadelphia, PA
    Posts
    4,708
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    This is a common issue for web based email. The only option you really have is to send an HTML email with the link in the source and short anchor text so it does not wrap:

    The issue is some web based email force email messages into a tighter space and force word wrap as well.

  3. #3
    SitePoint Enthusiast drorit30's Avatar
    Join Date
    May 2003
    Location
    tel aviv
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the quick response.
    If I understand correctly, if the link itself is very long, then it does not matter if the
    anchor text is short, since the web based email will wrap the link.

    So are you saying that this will also NOT work:
    <a href = "www.my site.com/site/validateRegistration.asp?email=newuser1@newuser.com&validateString=DHJHGFJKDGFGHJDGHJDHJGGDHJHGDHJ>CLICK HERE</a>

    which means that I need to make my link shorter?

    Thanks

  4. #4
    Original Gangster silver trophy Thing's Avatar
    Join Date
    Oct 2000
    Location
    Philadelphia, PA
    Posts
    4,708
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    That should work in an HTML email, since the only text showing for the link is CLICK HERE.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •