SitePoint Sponsor

User Tag List

Results 1 to 1 of 1
  1. #1
    SitePoint Member
    Join Date
    Apr 2005
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Rotatelogs not appearing to work...

    I'm running Apache on Windows 2000 Server and I'm trying to use ROTATELOGS to rotate my logs. Here's the httpd.conf file content I have:

    #
    # The location and format of the access logfile (Common Logfile Format).
    # If you do not define any access logfiles within a <VirtualHost>
    # container, they will be logged here. Contrariwise, if you *do*
    # define per-<VirtualHost> access logfiles, transactions will be
    # logged therein and *not* in this file.
    #

    #CustomLog logs/access.log common
    CustomLog "|bin/rotatelogs.exe logs/access.log 300M" common
    You can see the CustomLog entry that I did have, which I commented out and replaced with the lower entry.

    However, when I start apache using apache_start.bat, I just get the DOS window stating ...

    Diese Eingabeforderung nicht waehrend des Running beenden
    Bitte erst bei einem gewollten Shutdown schliessen
    Please close this command only for Shutdown
    Apache 2 is starting ...
    ...which then closes. Obviously, if I comment out my entry and uncomment out the original one, Apache starts OK.

    I've tried all sorts of combinations of comment, including using the TIME and MB options of ROTATELOGS.EXE, adding /APACHE/BIN/ to my path statement, using COMMON and COMBINED optionos, etc. but no luck. And yes, I can execute ROTATELOGS.EXE manually so the .EXE file is there.

    Any ideas?
    Last edited by tim_welch; Apr 8, 2005 at 07:03.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •